<!DOCTYPE html><html lang="en"><head><meta charset="utf-8"/><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no"/><link rel="canonical" href="https://www.clickorlando.com/entertainment/2021/01/15/noted-character-actor-peter-mark-richman-dies-at-93/"/><link rel="amphtml" href="https://www.clickorlando.com/entertainment/2021/01/15/noted-character-actor-peter-mark-richman-dies-at-93/?outputType=amp"/><title>Noted character actor Peter Mark Richman dies at 93</title><link rel="dns-prefetch" href="graham-wkmg.zeustechnology.com"/><link rel="dns-prefetch" href="securepubads.g.doubleclick.net"/><link rel="dns-prefetch" href="static.doubleclick.net"/><link rel="dns-prefetch" href="ib.adnxs.com"/><link rel="dns-prefetch" href="bidder.criteo.com"/><link rel="dns-prefetch" href="static.criteo.net"/><link rel="dns-prefetch" href="as-sec.casalemedia.com"/><link rel="dns-prefetch" href="js-sec.indexww.com"/><link rel="dns-prefetch" href="graham-d.openx.net"/><link rel="dns-prefetch" href="hbopenbid.pubmatic.com"/><link rel="dns-prefetch" href="fastlane.rubiconproject.com"/><link rel="dns-prefetch" href="ap.lijit.com"/><link rel="dns-prefetch" href="s.amazon-adsystem.com"/><link rel="dns-prefetch" href="tagan.adlightning.com"/><link rel="dns-prefetch" href="tpc.googlesyndication.com"/><link rel="dns-prefetch" href="www.googletagservices.com"/><link rel="dns-prefetch" href="fonts.googleapis.com"/><link rel="dns-prefetch" href="cdn.viafoura.net"/><link rel="dns-prefetch" href="ak.sail-horizon.com"/><link rel="dns-prefetch" href="wkmg-live.gmg.io"/><link rel="dns-prefetch" href="grahammedia.blueconic.net"/><meta property="og:url" content="https://www.clickorlando.com/entertainment/2021/01/15/noted-character-actor-peter-mark-richman-dies-at-93/"/><meta property="og:title" content="Noted character actor Peter Mark Richman dies at 93"/><meta property="og:type" content="article"/><meta property="og:description" content="Peter Mark Richman, a character actor who appeared in hundreds of television episodes and had recurring roles on “Three’s Company” and “Beverly Hills 90210,” has died."/><meta property="og:image" content="https://www.clickorlando.com/resizer/LxkvFkFR16h1p5aoMW2xx6GFQ4Y=/1600x1044/smart/filters:format(jpeg):strip_exif(true):strip_icc(true):no_upscale(true):quality(65)/cloudfront-us-east-1.images.arcpublishing.com/gmg/EKIBKDDRDNEQHJKQRVPPFSICF4.jpg"/><meta property="og:site_name" content="WKMG"/><meta property="og:locale" content="en_US"/><meta property="article:published_time" content="2021-01-15T05:31:54Z"/><meta property="article:modified_time" content="2021-01-15T05:38:04Z"/><meta property="article:section" content="Entertainment"/><meta property="article:tag" content="entertainment,Suzanne Somers,Edward Albee,Sophia Loren,Arts"/><meta property="article:content_tier" content="free"/><meta property="article:opinion" content="false"/><meta name="type" value="article"/><meta name="keywords" content="entertainment,Suzanne Somers,Edward Albee,Sophia Loren,Arts"/><meta name="content_id" content="LD44TMGZJNBVJL2FYJMHS6PWLY"/><meta name="author" content="Associated Press"/><meta name="description" content="Peter Mark Richman, a character actor who appeared in hundreds of television episodes and had recurring roles on “Three’s Company” and “Beverly Hills 90210,” has died."/><meta name="section_path" content="/entertainment"/><meta name="station" content="WKMG"/><meta name="line_count"/><meta name="word_count"/><meta name="inch_count"/><meta name="sailthru.author" content="Associated Press"/><meta name="sailthru.title" content="Noted character actor Peter Mark Richman dies at 93"/><meta name="sailthru.description" content="Peter Mark Richman, a character actor who appeared in hundreds of television episodes and had recurring roles on “Three’s Company” and “Beverly Hills 90210,” has died."/><meta name="sailthru.tags" content="entertainment,Suzanne Somers,Edward Albee,Sophia Loren,Arts"/><meta name="sailthru.date" content="2021-01-15T05:38:04Z"/><meta name="sailthru.image.full" content="https://www.clickorlando.com/resizer/LxkvFkFR16h1p5aoMW2xx6GFQ4Y=/1600x1044/smart/filters:format(jpeg):strip_exif(true):strip_icc(true):no_upscale(true):quality(65)/cloudfront-us-east-1.images.arcpublishing.com/gmg/EKIBKDDRDNEQHJKQRVPPFSICF4.jpg"/><meta name="sailthru.image.thumb" content="https://www.clickorlando.com/resizer/1Xttu3MkFItAZEUB1b3-BW2dWww=/380x248/smart/filters:format(jpeg):strip_exif(true):strip_icc(true):no_upscale(true):quality(65)/cloudfront-us-east-1.images.arcpublishing.com/gmg/EKIBKDDRDNEQHJKQRVPPFSICF4.jpg"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:title" content="Noted character actor Peter Mark Richman dies at 93"/><meta name="twitter:description" content="Peter Mark Richman, a character actor who appeared in hundreds of television episodes and had recurring roles on “Three’s Company” and “Beverly Hills 90210,” has died."/><meta name="twitter:site" content="WKMG"/><meta name="twitter:image" content="https://www.clickorlando.com/resizer/LxkvFkFR16h1p5aoMW2xx6GFQ4Y=/1600x1044/smart/filters:format(jpeg):strip_exif(true):strip_icc(true):no_upscale(true):quality(65)/cloudfront-us-east-1.images.arcpublishing.com/gmg/EKIBKDDRDNEQHJKQRVPPFSICF4.jpg"/><meta name="twitter:domain" content="https://www.clickorlando.com"/><meta property="fb:app_id" content="398048186916440"/><meta name="vf:unique_id" content="LD44TMGZJNBVJL2FYJMHS6PWLY"/><meta property="al:ios:url"/><meta property="al:ios:app_store_id" content="426128464"/><meta property="al:ios:app_name" content="clickorlando.com"/><meta property="al:android:url"/><meta property="al:android:package" content="com.ibsys.app.pns_orlpn"/><meta property="al:android:app_name" content="clickorlando.com"/><meta name="vf:topic" content="ENTERTAINMENT"/><meta name="vf:topic" content="SUZANNE SOMERS"/><meta name="vf:topic" content="EDWARD ALBEE"/><meta name="vf:topic" content="SOPHIA LOREN"/><meta name="vf:topic" content="ARTS"/><script src="https://cdn.blueconic.net/grahammedia.js" async=""></script><link rel="manifest" href="/manifest.json"/><meta name="coid" value="LD44TMGZJNBVJL2FYJMHS6PWLY"/><meta name="type" value="article"/><script type="application/javascript">if(!Array.prototype.includes||!(window.Object && window.Object.assign)||!window.Promise||!window.Symbol||!window.fetch){document.write('<script type="application/javascript" src="/pf/dist/engine/polyfill.js?d=238" defer=""><\/script>')}</script><script id="fusion-engine-script" type="application/javascript" src="/pf/dist/engine/react.js?d=238" defer=""></script><script id="fusion-engine-script" type="application/javascript" src="/pf/dist/components/combinations/default.js?d=238" defer=""></script><link id="fusion-template-styles" rel="stylesheet" type="text/css" href="/pf/dist/components/combinations/default.css?d=238"/><style data-styled="hVgEyq kaPImw dEUVZM gQHKfs hZkuHu bWgAyd eClSwW izLVSe iyKive eaRiyV buddlb hOwnIH kUmvoA bkwQBH bPweVN gipVYl fwWFwb fkPfnZ fTWKba evlRrf ilZUy fLEDfG kOvTIH dFsyvA caFKJk cZxrFf cOXxcV bUJyuH krEjWo dkolTS ewQCSW hnikHe ehxeFc ktXBcW fcJwUx ylsvi hyblkX cQtTJu lawncY bEvbcp dyBIXW gMbRFT hdIBsj cXgmBL hmSlYO KwVeF fdvoyR TtSCv kpbpkj hGrBwk fZwSNA bilTmH jyrenI eVARSm fUntZx dVhYib bhhsEY cquKod gCyhpK hdXTUS jdqXkR lfHSLi eLQosh jkffMn jAJRaJ hAfQFP ftzlFb jYxsit kjjmgb kJmJh kjNniI bvNIsv eQvXaU ftVFrR fMjoFB cHXwim eHAEsr fCYedq jutiOu kTyARq zZFXY eiHcFe cEPIdl qXBJx ibaJel esFqmh cxHMZc eRTCGg fSJjpK jEZict cCJuEP eRVpMB hhBaEp cHbzHq hYwgMt blUVki cSqiGO hUCozr RvfaP ghjhZl dIWLJt vWhsG egzwYP glXEHH fNIvUm cNQrfm lcbUVc inhNrD dCAhJS aXQaO XKwFB hOXVUV bCEGZq eFXIOu cEhwda iaEaZp zINiv dZqKUk doCIuX djEjnj jXGJFg dmosAa fVyska kNQmsx koAsuC jGOJAw jWZSqN dbFcvb kNcQME eEyOJW dACLKq ciyhmW fYkemh bONqtP kjNNpa lmYMxh kheGkZ YqQyK ikVUWL fPrfcR grIumH fUMYNQ cQLvZw eqGfgy fwgjJr gPLqwT jiGqvo ctUfOo MesSB ezHvnn jkmIMk bFxcaO fFDHFb dkZYCp budAcG eSYnrD jqqpuI gEUHxc igmKvm fZzsPf duwEoO hYFplq jQrCQI fwgKYc dYYMhQ kjYWfF dPfZIc kmbjsY dQflv gyjvDv ivMLjM jxqphP jpEiDS cEtgII cnjlQF bteNQB djNtkw eASEtv btjfNk djdbhj vPcWz QuPVf rBtYt jJzitT dvQPxZ eRyBdW iwhDXw iJhgZz jTvNHo hMeXfA iqNifc ewrPLn fSTleP fKUSaU glrVqB iOFmH eWHUGc iloZGO lbFKMV dreslZ boEUjA buODGt fsqOuA gplONQ dgPvxu fRGteW beZnNk xSDeK fqeedT jXFIWI dHsvLe itQApX eSpdOA vjvfn hqDRYI fpfjin kBWrPI GvITc kuaLBC caRkkC fMPmXx kMPYnx yUFmr glCTak hXBDjb iFsLET jQIrGc iSWmRc cVCQab cjejzq iVYcso jsNfTe brSUUa kxSfOz eNCNfa eizqqn cNqHWc gbyGMJ ikJztJ glnbYF kzUiqs jfWXex jZTmBd geXdgB eCyOrs dZTZZU gEZwaL iBYMTz driazD eTkyDI bskSxB bRsouh feZqle eLRlQd kjImDB hpOKeh pSHQY jpoqTS fJRMfg bnulPG ksWhTm fZvQVp hJrVIX pBbGO dBtQbC bcKvzU gSBgMQ duxpYf gDDInE ZFgox lpmiel kModZZ blcLbc evTcPc cFPnyr bFGfuZ bEpoPQ kgnbGC douMtc cYEOon hLsKLW cSwWXj jHUOWG bBhBvC lkXzOD jBwidz iKyiJg gsIsOL hafDZa iDyTTO doDWrK cQxHpD cLkntK eMwNva frMuCw euTivW birWca gzxeXn iJyOox iiIHmB bUaQcY jRZLpS cpEjCq ilUfQk fbEYHv eUMaTK LTBRG dPwxFc WMsMV llYxwN dPVvyW eCYLuL cVRsus guEeNZ gHduEw cJGkuD dHFlmA jeavfN cYoLTU fNgbDG kPZoOk dhWwbQ cRvPpt edpyEb gRSfXs jJGunR zGeDL dCEVY hsdwMN htnyAc lkQOLS cwlpln" data-styled-version="4.4.1">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</style><style>.async-hide { opacity: 0 !important}</style><script>(function(a,s,y,n,c,h,i,d,e){s.className+=' '+y;h.start=1*new Date;
    h.end=i=function(){s.className=s.className.replace(RegExp(' ?'+y),'')};
    (a[n]=a[n]||[]).hide=h;setTimeout(function(){i();h.end=null},c);h.timeout=c;
    })(window,document.documentElement,'async-hide','dataLayer',4000,
    {'GTM-MG7SZLK':true});</script><script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
    ga('create', 'UA-17717614-1', 'auto', {'useAmpClientId':true});
    ga('require', 'GTM-MG7SZLK');</script><script async="" src="https://www.googletagmanager.com/gtm/js?id=GTM-NQDG22W"></script><script>if (window) { window.dataLayer = window.dataLayer || [];
    window.dataLayer.push(
      {"siteId": "WKMG",
      'event':'gtm.js'
      }
    )}</script><script type="application/ld+json">{"@context":"https://schema.org","@type":"Article","headline":"Noted character actor Peter Mark Richman dies at 93","description":"Peter Mark Richman, a character actor who appeared in hundreds of television episodes and had recurring roles on “Three’s Company” and “Beverly Hills 90210,” has died.","url":"https://www.clickorlando.com/entertainment/2021/01/15/noted-character-actor-peter-mark-richman-dies-at-93/","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.clickorlando.com/entertainment/2021/01/15/noted-character-actor-peter-mark-richman-dies-at-93/"},"image":{"@type":"ImageObject","url":"https://www.clickorlando.com/resizer/1Xttu3MkFItAZEUB1b3-BW2dWww=/380x248/smart/filters:format(jpeg):strip_exif(true):strip_icc(true):no_upscale(true):quality(65)/cloudfront-us-east-1.images.arcpublishing.com/gmg/EKIBKDDRDNEQHJKQRVPPFSICF4.jpg","name":"FILE - In this Nov. 1, 2015, file photo, Peter Mark Richman arrives at the Hollywood Film Awards in Beverly Hills, Calif. Richman, a character actor who appeared in hundreds of television episodes and had recurring roles on Three's Company\" and Beverly Hills 90210,\" has died. He was 93. Richman died Thursday, Jan. 14, 2021, at his home in Los Angeles of natural causes, publicist Harlan Boll announced. (Photo by Jordan Strauss/Invision/AP, File)","width":300,"height":168},"datePublished":"2021-01-15T05:31:54Z","dateModified":"2021-01-15T05:38:04Z","publisher":{"@type":"Organization","name":"WKMG News 6 & ClickOrlando","logo":{"@type":"ImageObject","url":"https://t.gmg.io/amp/search/wkmg.png","name":"WKMG News 6 & ClickOrlando.com"}},"author":[{"@type":"Person","name":"Associated Press"}],"articleSection":"Entertainment","mentions":[{"@type":"Thing","name":"entertainment","url":"https://www.clickorlando.com/topic/entertainment/"},{"@type":"Thing","name":"Suzanne Somers","url":"https://www.clickorlando.com/topic/Suzanne_Somers/"},{"@type":"Thing","name":"Edward Albee","url":"https://www.clickorlando.com/topic/Edward_Albee/"},{"@type":"Thing","name":"Sophia Loren","url":"https://www.clickorlando.com/topic/Sophia_Loren/"},{"@type":"Thing","name":"Arts","url":"https://www.clickorlando.com/topic/Arts/"}],"keywords":["entertainment","Suzanne Somers","Edward Albee","Sophia Loren","Arts"]}</script><script src="/pf/resources/dist/wkmg/js/index.js?d=238"></script><link rel="stylesheet" href="/pf/resources/dist/wkmg/css/style.css?d=238"/><link rel="icon" type="image/x-icon" href="/pf/resources/images/wkmg/favicon.ico?d=238"/><script src="https://tagan.adlightning.com/grahammedia/op.js" defer=""></script><script src="https://c.amazon-adsystem.com/aax2/apstag.js" async=""></script><script>
    window.gmgAdUnitPath = "/15466288/WKMG/WEB//ENTERTAINMENT";
    window.zeusKeyvalues = {
      tags: "entertainment,Suzanne Somers,Edward Albee,Sophia Loren,Arts",
      type: "article",
      coid: "LD44TMGZJNBVJL2FYJMHS6PWLY"
    };
  </script><script src="https://graham-WKMG.zeustechnology.com/main.js" async="" id="__zeus_script"></script>
  <script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"true","rua.upre":"false","rua.cpre":"false","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-d19df04b-92e7-4f73-b81a-5a12c8e0f6a4","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false"}]);</script>
                          <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="SCEDS-P5UYQ-92N2P-RUTAN-BL3R9",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"SCEDS-P5UYQ-92N2P-RUTAN-BL3R9",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e="true"=="true"?1:0,t="",n="nml5ubaxglq4gyabiodq-f-261ec3ade-clientnsv4-s.akamaihd.net",i={"ak.v":"30","ak.cp":"890254","ak.ai":parseInt("569011",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"643cf1b","ak.r":30159,"ak.a2":e,"ak.m":"a","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":39228,"ak.gh":"23.50.225.191","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1610695559","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==YRImEu1A6zOJVd30J3Np0dr+CzC0YXqSDkd9Y2raugrnoxx6vdPEbuPpnvQC68KCMav2Hk427Xswc9YUWzj61oKTaZ/4ztlKUMdlLlO+eaaFjFvS4WgI9F8F+Pnq9wD7pIEdUhUpiBhqrEbaPfKsr/P/e8KpqsPfqB+Y9lCHU59Xmo3ao7u4kLV4q5P+uCzZNj2htYLNIbIhYO5Z43cKA6VB/1ZA9Ey/cCIIpkuE8hMfTkwNBTqurCyTeuND1UNK0kFoHupCdK8VMp2d7qhJ/WrJaUuWPJi2YceQBLCsWUsBlQwDYmfY6+CzDhiDpe0Gg9za0wNJAqsFFhBi/cABSK+zAWIOsAUt6pPUyyLf+evbDSgPnPKFEnYla8AqxyFjaf/Ev35yVIJCA49AmL/CV/rYyJAnv99CiOtH24ZHWBg=","ak.pv":"16","ak.dpoabenc":""};if(""!==t)i["ak.ruds"]=t;var _={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))i["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(i)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:i,akDNSPreFetchDomain:n,init:function(){if(!_.i){var a=BOOMR.subscribe;a("before_beacon",_.av,null,null),a("onbeacon",_.rv,null,null),_.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head><body class="" data-station="wkmg"><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NQDG22W" height="0" width="0" style="display:none;visibility:hidden" title="GTM"></iframe></noscript><div id="fusion-app"><header class="relative display_flex column justify_space_around align_items_center width_full font_gibson height_full"><div class="container relative display_flex justify_space_around align_items_center width_full width_max"><div class="burger-border display_flex justify_start align_left"><div class="burger pointer" href="#" role="button" tabindex="0"><div class="burger-icon"></div></div></div><a class="logo | display_flex | justify_center | align_items_center | height_full | color_white gaevent" href="/" gacategory="Nav" gaaction="Home" galabel="/"><div class="f1_container | relative | height_full | width_full"><div class="f1_card | shadow | display_flex | align_items_center | height_full | width_full"><div class="front | face | display_block | absolute | width_full" style="background-image:url(https://t.gmg.io/header/wkmg_front.svg)"></div><div class="back | face | absolute | width_full" style="background-image:url(https://t.gmg.io/header/wkmg_back.svg)"></div></div></div></a><div class="right display_flex align_items_center align_right height_full"><a href="/weather/" class="weather | display_flex | justify_center | align_items_center | height_full | color_white gaevent" gacategory="Nav" gaaction="Weather" galabel="/weather/"><img src="https://t.gmg.io/weather/currents/wx_97.svg" class="mr-xsm" style="max-height:33px"/><p class="font_openSans | font_bold | no-margin | uppercase">48<!-- -->ºF</p></a><button class="btn font_gibson transition-100 font_semibold signIn uppercase blue" name="" type="button" value="">Sign In</button><div class="viafoura"><vf-tray-trigger floating="false" style="display:none"></vf-tray-trigger></div></div></div><div class="burgerMenu color_white transition-500 display_none"><button class="btn font_gibson transition-100 width_max mCenter mb-norm display_block font_semibold signIn uppercase width_full blue" id="signIn" name="" type="button" value="">Sign In</button><div class="display_flex column width_max" style="margin:0 auto 1.5rem"><form action="/search/" class="search display_flex width_full mb-norm" id="navSearch" method="GET" name="" role="search"><div class="textFieldWrap relative font_openSans font_regular width_full"><input type="text" aria-invalid="false" autoComplete="" class="transition-500 rg" id="navSearchInputBox" name="searchTerm" placeholder="Search" value=""/><label for="navSearchInputBox" class="transition-100 text_left absolute font_gibson font_medium"></label></div><button class="btn font_gibson transition-100 display_none font_semibold blue" name="" type="button" value="" style="flex:1">Search</button></form><div class="socialContainer width_full"><ul class="display_flex justify_space_between height_full no-margin"><li class="display_flex align_items_center"><a class="link white gaevent" href="https://www.facebook.com/news6/" gacategory="Nav" gaaction="Hamburger Social" galabel="https://www.facebook.com/news6/"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="facebook" class="svg-inline--fa fa-facebook fa-w-16 transition-500" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512" style="max-height:2rem"><path fill="currentColor" d="M504 256C504 119 393 8 256 8S8 119 8 256c0 123.78 90.69 226.38 209.25 245V327.69h-63V256h63v-54.64c0-62.15 37-96.48 93.67-96.48 27.14 0 55.52 4.84 55.52 4.84v61h-31.28c-30.8 0-40.41 19.12-40.41 38.73V256h68.78l-11 71.69h-57.78V501C413.31 482.38 504 379.78 504 256z"></path></svg></a></li><li class="display_flex align_items_center"><a class="link white gaevent" href="https://twitter.com/news6wkmg/" gacategory="Nav" gaaction="Hamburger Social" galabel="https://twitter.com/news6wkmg/"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="twitter" class="svg-inline--fa fa-twitter fa-w-16 transition-500" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512" style="max-height:2rem"><path fill="currentColor" d="M459.37 151.716c.325 4.548.325 9.097.325 13.645 0 138.72-105.583 298.558-298.558 298.558-59.452 0-114.68-17.219-161.137-47.106 8.447.974 16.568 1.299 25.34 1.299 49.055 0 94.213-16.568 130.274-44.832-46.132-.975-84.792-31.188-98.112-72.772 6.498.974 12.995 1.624 19.818 1.624 9.421 0 18.843-1.3 27.614-3.573-48.081-9.747-84.143-51.98-84.143-102.985v-1.299c13.969 7.797 30.214 12.67 47.431 13.319-28.264-18.843-46.781-51.005-46.781-87.391 0-19.492 5.197-37.36 14.294-52.954 51.655 63.675 129.3 105.258 216.365 109.807-1.624-7.797-2.599-15.918-2.599-24.04 0-57.828 46.782-104.934 104.934-104.934 30.213 0 57.502 12.67 76.67 33.137 23.715-4.548 46.456-13.32 66.599-25.34-7.798 24.366-24.366 44.833-46.132 57.827 21.117-2.273 41.584-8.122 60.426-16.243-14.292 20.791-32.161 39.308-52.628 54.253z"></path></svg></a></li><li class="display_flex align_items_center"><a class="link white gaevent" href="https://www.instagram.com/news6wkmg/" gacategory="Nav" gaaction="Hamburger Social" galabel="https://www.instagram.com/news6wkmg/"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="instagram" class="svg-inline--fa fa-instagram fa-w-14 transition-500" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512" style="max-height:2rem"><path fill="currentColor" d="M224.1 141c-63.6 0-114.9 51.3-114.9 114.9s51.3 114.9 114.9 114.9S339 319.5 339 255.9 287.7 141 224.1 141zm0 189.6c-41.1 0-74.7-33.5-74.7-74.7s33.5-74.7 74.7-74.7 74.7 33.5 74.7 74.7-33.6 74.7-74.7 74.7zm146.4-194.3c0 14.9-12 26.8-26.8 26.8-14.9 0-26.8-12-26.8-26.8s12-26.8 26.8-26.8 26.8 12 26.8 26.8zm76.1 27.2c-1.7-35.9-9.9-67.7-36.2-93.9-26.2-26.2-58-34.4-93.9-36.2-37-2.1-147.9-2.1-184.9 0-35.8 1.7-67.6 9.9-93.9 36.1s-34.4 58-36.2 93.9c-2.1 37-2.1 147.9 0 184.9 1.7 35.9 9.9 67.7 36.2 93.9s58 34.4 93.9 36.2c37 2.1 147.9 2.1 184.9 0 35.9-1.7 67.7-9.9 93.9-36.2 26.2-26.2 34.4-58 36.2-93.9 2.1-37 2.1-147.8 0-184.8zM398.8 388c-7.8 19.6-22.9 34.7-42.6 42.6-29.5 11.7-99.5 9-132.1 9s-102.7 2.6-132.1-9c-19.6-7.8-34.7-22.9-42.6-42.6-11.7-29.5-9-99.5-9-132.1s-2.6-102.7 9-132.1c7.8-19.6 22.9-34.7 42.6-42.6 29.5-11.7 99.5-9 132.1-9s102.7-2.6 132.1 9c19.6 7.8 34.7 22.9 42.6 42.6 11.7 29.5 9 99.5 9 132.1s2.7 102.7-9 132.1z"></path></svg></a></li><li class="display_flex align_items_center"><a class="link white gaevent" href="https://www.clickorlando.com/rss/" gacategory="Nav" gaaction="Hamburger Social" galabel="https://www.clickorlando.com/rss/"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="rss" class="svg-inline--fa fa-rss fa-w-14 transition-500" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512" style="max-height:2rem"><path fill="currentColor" d="M128.081 415.959c0 35.369-28.672 64.041-64.041 64.041S0 451.328 0 415.959s28.672-64.041 64.041-64.041 64.04 28.673 64.04 64.041zm175.66 47.25c-8.354-154.6-132.185-278.587-286.95-286.95C7.656 175.765 0 183.105 0 192.253v48.069c0 8.415 6.49 15.472 14.887 16.018 111.832 7.284 201.473 96.702 208.772 208.772.547 8.397 7.604 14.887 16.018 14.887h48.069c9.149.001 16.489-7.655 15.995-16.79zm144.249.288C439.596 229.677 251.465 40.445 16.503 32.01 7.473 31.686 0 38.981 0 48.016v48.068c0 8.625 6.835 15.645 15.453 15.999 191.179 7.839 344.627 161.316 352.465 352.465.353 8.618 7.373 15.453 15.999 15.453h48.068c9.034-.001 16.329-7.474 16.005-16.504z"></path></svg></a></li></ul></div></div><nav class="navItems font_bold width_max mCenter"><ul class="nav display_grid width_max mCenter"><li class="primary"><ul class="secondary"><li class="parent mb-sm"><a class="link white gaevent" href="/news/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/news"><strong>News</strong></a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/watch-live/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/watch-live/" gavalue="0">Watch Live</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/news/investigators/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/news/investigators" gavalue="1">Investigators</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/News_6_At_Nine/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/News_6_At_Nine/" gavalue="2">News 6 At Nine</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/news/local/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/news/local" gavalue="3">Local News</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/news/florida/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/news/florida" gavalue="4">Florida</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/news/national/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/news/national" gavalue="5">National</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/news/world/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/news/world" gavalue="6">World</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/results-2020/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/results-2020/" gavalue="7">Election Results 2020</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/news/politics/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/news/politics" gavalue="8">Politics</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Space/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Space/" gavalue="9">Space News</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Trust_Index/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Trust_Index/" gavalue="10">Trust Index</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Coronavirus/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Coronavirus/" gavalue="11">Coronavirus</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Vaccine/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Vaccine/" gavalue="12">Vaccine</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Do_Your_Part/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Do_Your_Part/" gavalue="13">Do Your Part</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/entertainment/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/entertainment" gavalue="14">Entertainment</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Strange_Florida/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Strange_Florida/" gavalue="15">Strange Florida</a></li></ul></li><li class="primary"><ul class="secondary"><li class="parent mb-sm"><a class="link white gaevent" href="/getting-results/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/getting-results"><strong>Getting Results.</strong></a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Weekly/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Weekly/" gavalue="0">The Weekly</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Driving_Change/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Driving_Change/" gavalue="1">Driving Change</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Getting_Results_On_Crime/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Getting_Results_On_Crime/" gavalue="2">Getting Results On Crime</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Getting_Results_For_Our_Schools/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Getting_Results_For_Our_Schools/" gavalue="3">Getting Results For Our Schools</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Getting_Results_For_Your_Health/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Getting_Results_For_Your_Health/" gavalue="4">Getting Results For Your Health</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Award_Winners/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Award_Winners/" gavalue="5">Award Winners</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/getting-results/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/getting-results/" gavalue="6">Need Results?</a></li></ul></li><li class="primary"><ul class="secondary"><li class="parent mb-sm"><a class="link white gaevent" href="/weather/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/weather"><strong>Weather</strong></a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Weather_News/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Weather_News/" gavalue="0">Weather News</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/pins/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/pins" gavalue="1">Pin It!</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/hurricane/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/hurricane/" gavalue="2">Hurricane</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/weather/alerts/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/weather/alerts/" gavalue="3">Alerts</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/news/2019/11/11/live-camera-orlando-health/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/news/2019/11/11/live-camera-orlando-health/" gavalue="4">Live Orlando Cam</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/news/2019/11/12/live-camera-daytona-beach/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/news/2019/11/12/live-camera-daytona-beach/" gavalue="5">Live Beach Cam</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/news/local/2020/01/30/live-camera-port-canaveral/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/news/local/2020/01/30/live-camera-port-canaveral/" gavalue="6">Live Port Cam</a></li></ul></li><li class="primary"><ul class="secondary"><li class="parent mb-sm"><a class="link white gaevent" href="/traffic/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/traffic"><strong>Traffic</strong></a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/news/ask-trooper-steve/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/news/ask-trooper-steve" gavalue="0">Ask Trooper Steve</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/What_The_Honk/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/What_The_Honk/" gavalue="1">What The Honk?</a></li></ul></li><li class="primary"><ul class="secondary"><li class="parent mb-sm"><a class="link white gaevent" href="/features/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/features"><strong>Features</strong></a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Trust_Index/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Trust_Index/" gavalue="0">Trust Index</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/theme-parks/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/theme-parks" gavalue="1">Theme Parks</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/pets/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/pets/" gavalue="2">Pets</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/food/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/food" gavalue="3">Food</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/health/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/health" gavalue="4">Health</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Travel/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Travel/" gavalue="5">Travel</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Valentines/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Valentines/" gavalue="6">Valentine&#x27;s Day</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Make_Ends_Meet/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Make_Ends_Meet/" gavalue="7">Make Ends Meet</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/money/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/money" gavalue="8">Money</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/tech/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/tech" gavalue="9">Tech</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Something_Good/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Something_Good/" gavalue="10">Something Good</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Pros_Who_Know/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Pros_Who_Know/" gavalue="11">Pros Who Know</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/StyleWise/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/StyleWise/" gavalue="12">StyleWise</a></li></ul></li><li class="primary"><ul class="secondary"><li class="parent mb-sm"><a class="link white gaevent" href="/topic/podcasts/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/topic/podcasts"><strong>Podcasts</strong></a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Florida_Foodie/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Florida_Foodie/" gavalue="0">Florida Foodie</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Fourth_Estate/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Fourth_Estate/" gavalue="1">Fourth Estate</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Space_Curious/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Space_Curious/" gavalue="2">Space Curious</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Hecht_Effect/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Hecht_Effect/" gavalue="3">The Hecht Effect</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Ask_Holly/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Ask_Holly/" gavalue="4">Ask Holly</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Puckcast/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Puckcast/" gavalue="5">Puckcast</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Real_Estate_With_Justin_Clark/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Real_Estate_With_Justin_Clark/" gavalue="6">Real Estate</a></li></ul></li><li class="primary"><ul class="secondary"><li class="parent mb-sm"><a class="link white gaevent" href="/sports/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/sports"><strong>Sports</strong></a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Magic/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Magic/" gavalue="0">Orlando Magic</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Knights/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Knights/" gavalue="1">UCF Knights</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Gators/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Gators/" gavalue="2">Florida Gators</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Orlando_City/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Orlando_City/" gavalue="3">Orlando City SC</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Orlando_Pride/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Orlando_Pride/" gavalue="4">Orlando Pride</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Dolphins/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Dolphins/" gavalue="5">Miami Dolphins</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Buccaneers/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Buccaneers/" gavalue="6">Tampa Bay Buccaneers</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Jaguars/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Jaguars/" gavalue="7">Jacksonville Jaguars</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/topic/Solar_Bears/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Solar_Bears/" gavalue="8">Orlando Solar Bears</a></li></ul></li><li class="primary"><ul class="secondary"><li class="parent mb-sm"><a class="link white gaevent" href="/station/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/station"><strong>WKMG</strong></a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/team/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/team/" gavalue="0">Meet The Team</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/contact/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/contact/" gavalue="1">Contact Us</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/careers/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/careers" gavalue="2">Careers at WKMG</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/contests/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/contests/" gavalue="3">Contests &amp; Rules</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/tv-listings/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/tv-listings/" gavalue="4">TV Listings</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/community-calendar/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/community-calendar/" gavalue="5">Community Calendar</a></li><li class="sub mb-sm"><a class="font_regular gaevent" href="/account/newsletters/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/account/newsletters/" gavalue="6">Newsletters</a></li></ul></li><li class="primary"><ul class="secondary"><li class="parent mb-sm"><a class="link white gaevent" href="/account/newsletters/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/account/newsletters/"><strong>Newsletters</strong></a></li></ul></li></ul></nav></div><nav class="spotlight | justify_center | align_items_center | width_full"><ul class="display_flex | justify_space_between | no-margin | uppercase | width_full"><li><a class="link white gaevent" href="/news/" gacategory="Nav" gaaction="Spotlight" galabel="/news/">News</a></li><li><a class="link white gaevent" href="/getting-results/" gacategory="Nav" gaaction="Spotlight" galabel="/getting-results/">Getting Results.</a></li><li><a class="link white gaevent" href="/weather/" gacategory="Nav" gaaction="Spotlight" galabel="/weather/">Weather</a></li><li><a class="link white gaevent" href="/traffic/" gacategory="Nav" gaaction="Spotlight" galabel="/traffic/">Traffic</a></li><li><a class="link white gaevent" href="/features/" gacategory="Nav" gaaction="Spotlight" galabel="/features/">Features</a></li><li><a class="link white gaevent" href="/topic/podcasts/" gacategory="Nav" gaaction="Spotlight" galabel="/topic/podcasts/">Podcasts</a></li><li><a class="link white gaevent" href="/sports/" gacategory="Nav" gaaction="Spotlight" galabel="/sports/">Sports</a></li><li><a class="link white gaevent" href="/station/" gacategory="Nav" gaaction="Spotlight" galabel="/station/">WKMG</a></li><li><a class="link white gaevent" href="/account/newsletters/" gacategory="Nav" gaaction="Spotlight" galabel="/account/newsletters/">Newsletters</a></li></ul></nav><div id="mini" class="fixed justify_center transition-300"><div class="container display_flex align_items_center width_full width_max"><div class="burger-border display_flex" role="button" tabindex="0"><div class="burger" href="#"><div class="burger-icon"></div></div></div><a class="logo" href="/"><img src="https://t.gmg.io/header/favicon/wkmg.svg" alt="ClickOrlando.com"/></a><nav><ul class="display_flex no-margin font_semibold transition-500"><li><a class="link white | uppercase gaevent" href="/news/" gacategory="Nav" gaaction="MiniBar" galabel="/news/" gavalue="0">News</a></li><li><a class="link white | uppercase gaevent" href="/getting-results/" gacategory="Nav" gaaction="MiniBar" galabel="/getting-results/" gavalue="1">Getting Results.</a></li><li><a class="link white | uppercase gaevent" href="/weather/" gacategory="Nav" gaaction="MiniBar" galabel="/weather/" gavalue="2">Weather</a></li><li><a class="link white | uppercase gaevent" href="/traffic/" gacategory="Nav" gaaction="MiniBar" galabel="/traffic/" gavalue="3">Traffic</a></li><li><a class="link white | uppercase gaevent" href="/features/" gacategory="Nav" gaaction="MiniBar" galabel="/features/" gavalue="4">Features</a></li><li><a class="link white | uppercase gaevent" href="/topic/podcasts/" gacategory="Nav" gaaction="MiniBar" galabel="/topic/podcasts/" gavalue="5">Podcasts</a></li><li><a class="link white | uppercase gaevent" href="/sports/" gacategory="Nav" gaaction="MiniBar" galabel="/sports/" gavalue="6">Sports</a></li><li><a class="link white | uppercase gaevent" href="/station/" gacategory="Nav" gaaction="MiniBar" galabel="/station/" gavalue="7">WKMG</a></li><li><a class="link white | uppercase gaevent" href="/account/newsletters/" gacategory="Nav" gaaction="MiniBar" galabel="/account/newsletters/" gavalue="8">Newsletters</a></li></ul></nav><div class="right display_flex align_items_center"><a href="/weather/" class="weather | display_flex | justify_center | align_items_center | height_full | color_white gaevent" gacategory="Nav" gaaction="Weather" galabel="/weather/"><img src="https://t.gmg.io/weather/currents/wx_97.svg" class="mr-xsm" style="max-height:33px"/><p class="font_openSans | font_bold | no-margin | uppercase">48<!-- -->ºF</p></a><button class="btn font_gibson transition-100 font_semibold mini signIn uppercase blue" name="" type="button" value="">Sign In</button></div></div></div></header><section class="wrapper"><main class="article" role="main"><section class="top-wide"><div class="scGrid full-width twoCol" id="0f4QEZVpGrA"></div></section><aside id="article" class="display_none font_gibson"><section class="chainGroup" id="0f1VvA1iDrr"><div class="articleInfo"><h4 class="mb-sm color_black uppercase mb-sm color_black uppercase mb-sm" style="text-transform:uppercase"><a class="link default | gaevent" href="/entertainment" gacategory="Article Rail" gaaction="Section Link" galabel="Entertainment">Entertainment</a></h4><hr class="bold" style="margin-bottom:0rem"/><div class="Box-sc-12ejyki-0 kJmJh metadata"><div class="Box-sc-12ejyki-0 kjNniI byline"><p class="Text__BaseText-mmkwcw-0 cLkntK author">Associated Press</p></div><div class="Box-sc-12ejyki-0 bvNIsv time"><time class="Text__BaseText-mmkwcw-0 lkXzOD" dateTime="2021-01-15T05:31:54Z">Published: <span class="Text__BaseText-mmkwcw-0 jBwidz"><time dateTime="1610688714000" class="">January 15, 2021, 12:31 am</time></span></time><time class="Text__BaseText-mmkwcw-0 lkXzOD" dateTime="2021-01-15T05:38:04Z">Updated: <span class="Text__BaseText-mmkwcw-0 jBwidz"><time dateTime="1610689084000" class="">January 15, 2021, 12:38 am</time></span></time></div><div class="Box-sc-12ejyki-0 jkffMn tags">Tags: <span class="Text__BaseText-mmkwcw-0 hLsKLW"><a href="/topic/entertainment/" class="Link__LinkBase-h1izp9-0 dhWwbQ">entertainment</a>, <a href="/topic/Suzanne_Somers/" class="Link__LinkBase-h1izp9-0 dhWwbQ">Suzanne Somers</a>, <a href="/topic/Edward_Albee/" class="Link__LinkBase-h1izp9-0 dhWwbQ">Edward Albee</a>, <a href="/topic/Sophia_Loren/" class="Link__LinkBase-h1izp9-0 dhWwbQ">Sophia Loren</a>, <a href="/topic/Arts/" class="Link__LinkBase-h1izp9-0 dhWwbQ">Arts</a></span></div></div><hr class="Divider-sc-1n9x3vv-0 zGeDL"/></div><h5>Sign up for our Newsletters</h5><form action="" class="formField transition-300 mb-med" encType="application/x-www-form-urlencoded" method="GET" name="" role=""><div class="textFieldWrap relative font_openSans font_regular"><input type="email" aria-invalid="false" autoComplete="" class="transition-500 sm" name="email" placeholder="Enter your email here!" value=""/><label class="transition-100 text_left absolute font_gibson font_medium"></label></div></form><div id="fusion-static-enter:0faiKp1iDrJ" style="display:none"></div><div class="social-share | display_flex | mb-norm | justify_center | align_items_center"><div class="viafoura"><div class="vf-widget vf-share-bar-circle vf-share-bar-bw" data-widget="sharebar" data-button-view="false" data-show-labels="false" data-show-counters="false" data-show-total="false" data-share-current-page-url="true"></div></div><div class="viafoura"><a class="com-anchor | display_block | color_black" href="#comments"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="comments" class="svg-inline--fa fa-comments fa-w-18 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 576 512" style="max-height:1.5rem"><path fill="currentColor" d="M416 192c0-88.4-93.1-160-208-160S0 103.6 0 192c0 34.3 14.1 65.9 38 92-13.4 30.2-35.5 54.2-35.8 54.5-2.2 2.3-2.8 5.7-1.5 8.7S4.8 352 8 352c36.6 0 66.9-12.3 88.7-25 32.2 15.7 70.3 25 111.3 25 114.9 0 208-71.6 208-160zm122 220c23.9-26 38-57.7 38-92 0-66.9-53.5-124.2-129.3-148.1.9 6.6 1.3 13.3 1.3 20.1 0 105.9-107.7 192-240 192-10.8 0-21.3-.8-31.7-1.9C207.8 439.6 281.8 480 368 480c41 0 79.1-9.2 111.3-25 21.8 12.7 52.1 25 88.7 25 3.2 0 6.1-1.9 7.3-4.8 1.3-2.9.7-6.3-1.5-8.7-.3-.3-22.4-24.2-35.8-54.5z"></path></svg><span class="vf-counter vf-widget font_gibson font_semibold" data-widget="counter"></span></a></div></div><hr class="Divider-sc-1n9x3vv-0 dCEVY"/><div id="fusion-static-exit:0faiKp1iDrJ" style="display:none"></div></section><aside id="0fPgeUQdGrU" class="sticky" style="display:flex;flex-direction:column;justify-content:space-around;align-items:flex-start"><section class="storyList"><h4 class="mb-sm" style="text-transform:uppercase">Latest News</h4><hr class="bold" style="margin-bottom:1rem"/><section class="topic textOverlay full-width gap_x_norm gap_y_lg"><div class="grid story-list gap_x_norm gap_y_norm vertical"><article class="storyCard mb-norm"><div class="Box-sc-12ejyki-0 ehxeFc relative min gridItem height_full horizontal"><div class="Box-sc-12ejyki-0 ktXBcW"><a href="/news/local/2021/01/15/marion-deputies-identify-man-wanted-for-beating-womans-car-with-baseball-bat/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/01/15/marion-deputies-identify-man-wanted-for-beating-womans-car-with-baseball-bat/" gavalue="0"><div class="image relative height_full"><figure class="Box-sc-12ejyki-0 kaPImw relative width_full height_full"><div class="Box-sc-12ejyki-0 ilZUy"><img src="/pf/resources/images/shared/placeholder.svg?d=238" style="object-fit:cover;position:absolute;top:0;right:0;bottom:0;left:0;width:100%;height:100%" alt="Marion deputies identify man wanted for beating woman’s car with baseball bat"/></div></figure></div></a></div><div class="Box-sc-12ejyki-0 fLEDfG articleMeta width_full"><div class="Box-sc-12ejyki-0 fcJwUx"><a href="/news/local/2021/01/15/marion-deputies-identify-man-wanted-for-beating-womans-car-with-baseball-bat/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/01/15/marion-deputies-identify-man-wanted-for-beating-womans-car-with-baseball-bat/" gavalue="0">3 hours ago</a></div><a class="display_block gaevent" href="/news/local/2021/01/15/marion-deputies-identify-man-wanted-for-beating-womans-car-with-baseball-bat/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/01/15/marion-deputies-identify-man-wanted-for-beating-womans-car-with-baseball-bat/" gavalue="0"><h3 class="no-margin">Marion deputies identify man wanted for beating woman’s car with baseball bat</h3></a></div></div></article><hr class="regular"/><article class="storyCard mb-norm"><div class="Box-sc-12ejyki-0 ehxeFc relative min gridItem height_full horizontal"><div class="Box-sc-12ejyki-0 ktXBcW"><a href="/news/local/2021/01/15/how-cold-will-it-get-this-weekend-in-central-florida/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/01/15/how-cold-will-it-get-this-weekend-in-central-florida/" gavalue="1"><div class="image relative height_full"><figure class="Box-sc-12ejyki-0 kaPImw relative width_full height_full"><div class="Box-sc-12ejyki-0 ilZUy"><img src="/pf/resources/images/shared/placeholder.svg?d=238" style="object-fit:cover;position:absolute;top:0;right:0;bottom:0;left:0;width:100%;height:100%" alt="How cold will it get in Central Florida this weekend?"/></div></figure></div></a></div><div class="Box-sc-12ejyki-0 fLEDfG articleMeta width_full"><div class="Box-sc-12ejyki-0 fcJwUx"><a href="/news/local/2021/01/15/how-cold-will-it-get-this-weekend-in-central-florida/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/01/15/how-cold-will-it-get-this-weekend-in-central-florida/" gavalue="1">4 hours ago</a></div><a class="display_block gaevent" href="/news/local/2021/01/15/how-cold-will-it-get-this-weekend-in-central-florida/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/01/15/how-cold-will-it-get-this-weekend-in-central-florida/" gavalue="1"><h3 class="no-margin">How cold will it get in Central Florida this weekend?</h3></a></div></div></article><hr class="regular"/><article class="storyCard mb-norm"><div class="Box-sc-12ejyki-0 ehxeFc relative min gridItem height_full horizontal"><div class="Box-sc-12ejyki-0 ktXBcW"><a href="/news/local/2021/01/14/do-you-need-help-orlando-server-uses-sign-to-help-rescue-abused-boy-police-say/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/01/14/do-you-need-help-orlando-server-uses-sign-to-help-rescue-abused-boy-police-say/" gavalue="2"><div class="image relative height_full"><figure class="Box-sc-12ejyki-0 kaPImw relative width_full height_full"><div class="Box-sc-12ejyki-0 ilZUy"><img src="/pf/resources/images/shared/placeholder.svg?d=238" style="object-fit:cover;position:absolute;top:0;right:0;bottom:0;left:0;width:100%;height:100%" alt="‘Do you need help?’ Orlando restaurant manager uses secret sign to help rescue abused boy, police say"/></div></figure></div></a></div><div class="Box-sc-12ejyki-0 fLEDfG articleMeta width_full"><div class="Box-sc-12ejyki-0 fcJwUx"><a href="/news/local/2021/01/14/do-you-need-help-orlando-server-uses-sign-to-help-rescue-abused-boy-police-say/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/01/14/do-you-need-help-orlando-server-uses-sign-to-help-rescue-abused-boy-police-say/" gavalue="2">6 hours ago</a></div><a class="display_block gaevent" href="/news/local/2021/01/14/do-you-need-help-orlando-server-uses-sign-to-help-rescue-abused-boy-police-say/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/01/14/do-you-need-help-orlando-server-uses-sign-to-help-rescue-abused-boy-police-say/" gavalue="2"><h3 class="no-margin">‘Do you need help?’ Orlando restaurant manager uses secret sign to help rescue abused boy, police say</h3></a></div></div></article><hr class="regular"/><article class="storyCard mb-norm"><div class="Box-sc-12ejyki-0 ehxeFc relative min gridItem height_full horizontal"><div class="Box-sc-12ejyki-0 ktXBcW"><a href="/news/local/2021/01/14/orlando-restaurant-manager-saved-the-life-of-boy-who-was-severely-abused-chief-says/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/01/14/orlando-restaurant-manager-saved-the-life-of-boy-who-was-severely-abused-chief-says/" gavalue="3"><div class="image relative height_full"><figure class="Box-sc-12ejyki-0 kaPImw relative width_full height_full"><div class="Box-sc-12ejyki-0 ilZUy"><img src="/pf/resources/images/shared/placeholder.svg?d=238" style="object-fit:cover;position:absolute;top:0;right:0;bottom:0;left:0;width:100%;height:100%" alt="Orlando restaurant manager ‘saved the life’ of boy who was severely abused, chief says"/></div></figure></div></a></div><div class="Box-sc-12ejyki-0 fLEDfG articleMeta width_full"><div class="Box-sc-12ejyki-0 fcJwUx"><a href="/news/local/2021/01/14/orlando-restaurant-manager-saved-the-life-of-boy-who-was-severely-abused-chief-says/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/01/14/orlando-restaurant-manager-saved-the-life-of-boy-who-was-severely-abused-chief-says/" gavalue="3">6 hours ago</a></div><a class="display_block gaevent" href="/news/local/2021/01/14/orlando-restaurant-manager-saved-the-life-of-boy-who-was-severely-abused-chief-says/" gacategory="Story Card" gaaction="Story List" galabel="/news/local/2021/01/14/orlando-restaurant-manager-saved-the-life-of-boy-who-was-severely-abused-chief-says/" gavalue="3"><h3 class="no-margin">Orlando restaurant manager ‘saved the life’ of boy who was severely abused, chief says</h3></a></div></div></article></div></section></section></aside></aside><section class="mainContent"><div class="Box-sc-12ejyki-0 cHbzHq articleInfo"><h4 class="Header__StyledHeader-qoaq48-0 eCYLuL"><a href="/entertainment">Entertainment</a></h4></div><article class="Box-sc-12ejyki-0 hYwgMt story"><div class="Box-sc-12ejyki-0 blUVki"><h1 class="Header__StyledHeader-qoaq48-0 cVRsus headline">Noted character actor Peter Mark Richman dies at 93</h1></div><div class="Box-sc-12ejyki-0 cSqiGO metadata"><div class="Box-sc-12ejyki-0 kjNniI byline"><p class="Text__BaseText-mmkwcw-0 cLkntK author">Associated Press</p></div><div class="Box-sc-12ejyki-0 bvNIsv time"><time class="Text__BaseText-mmkwcw-0 lkXzOD" dateTime="2021-01-15T05:31:54Z">Published: <span class="Text__BaseText-mmkwcw-0 jBwidz"><time dateTime="1610688714000" class="">January 15, 2021, 12:31 am</time></span></time><time class="Text__BaseText-mmkwcw-0 lkXzOD" dateTime="2021-01-15T05:38:04Z">Updated: <span class="Text__BaseText-mmkwcw-0 jBwidz"><time dateTime="1610689084000" class="">January 15, 2021, 12:38 am</time></span></time></div><div class="Box-sc-12ejyki-0 jkffMn tags">Tags: <span class="Text__BaseText-mmkwcw-0 hLsKLW"><a href="/topic/entertainment/" class="Link__LinkBase-h1izp9-0 dhWwbQ">entertainment</a>, <a href="/topic/Suzanne_Somers/" class="Link__LinkBase-h1izp9-0 dhWwbQ">Suzanne Somers</a>, <a href="/topic/Edward_Albee/" class="Link__LinkBase-h1izp9-0 dhWwbQ">Edward Albee</a>, <a href="/topic/Sophia_Loren/" class="Link__LinkBase-h1izp9-0 dhWwbQ">Sophia Loren</a>, <a href="/topic/Arts/" class="Link__LinkBase-h1izp9-0 dhWwbQ">Arts</a></span></div></div><div display="block" class="Box-sc-12ejyki-0 hUCozr"><figure class="Box-sc-12ejyki-0 kaPImw relative promo full-width"><div class="Box-sc-12ejyki-0 bEpoPQ"><img src="/pf/resources/images/shared/placeholder.svg?d=238" style="object-fit:cover;position:absolute;top:0;right:0;bottom:0;left:0;width:100%;height:100%" alt="FILE - In this Nov. 1, 2015, file photo, Peter Mark Richman arrives at the Hollywood Film Awards in Beverly Hills, Calif. Richman, a character actor who appeared in hundreds of television episodes and had recurring roles on Three&#x27;s Company&quot; and Beverly Hills 90210,&quot; has died. He was 93. Richman died Thursday, Jan. 14, 2021, at his home in Los Angeles of natural causes, publicist Harlan Boll announced. (Photo by Jordan Strauss/Invision/AP, File)"/></div><figcaption class="Box-sc-12ejyki-0 XKwFB"><span class="Text__BaseText-mmkwcw-0 frMuCw">FILE - In this Nov. 1, 2015, file photo, Peter Mark Richman arrives at the Hollywood Film Awards in Beverly Hills, Calif. Richman, a character actor who appeared in hundreds of television episodes and had recurring roles on Three's Company" and Beverly Hills 90210," has died. He was 93. Richman died Thursday, Jan. 14, 2021, at his home in Los Angeles of natural causes, publicist Harlan Boll announced. (Photo by Jordan Strauss/Invision/AP, File)</span></figcaption></figure><section class="Box-sc-12ejyki-0 fNIvUm articleBody" itemProp="articleBody"><div class="mobileOnly"><div class="social-share | display_flex | mb-norm | justify_center | align_items_center"><div class="viafoura"><div class="vf-widget vf-share-bar-circle vf-share-bar-bw" data-widget="sharebar" data-button-view="false" data-show-labels="false" data-show-counters="false" data-show-total="false" data-share-current-page-url="true"></div></div><div class="viafoura"><a class="com-anchor | display_block | color_black" href="#comments"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="comments" class="svg-inline--fa fa-comments fa-w-18 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 576 512" style="max-height:1.5rem"><path fill="currentColor" d="M416 192c0-88.4-93.1-160-208-160S0 103.6 0 192c0 34.3 14.1 65.9 38 92-13.4 30.2-35.5 54.2-35.8 54.5-2.2 2.3-2.8 5.7-1.5 8.7S4.8 352 8 352c36.6 0 66.9-12.3 88.7-25 32.2 15.7 70.3 25 111.3 25 114.9 0 208-71.6 208-160zm122 220c23.9-26 38-57.7 38-92 0-66.9-53.5-124.2-129.3-148.1.9 6.6 1.3 13.3 1.3 20.1 0 105.9-107.7 192-240 192-10.8 0-21.3-.8-31.7-1.9C207.8 439.6 281.8 480 368 480c41 0 79.1-9.2 111.3-25 21.8 12.7 52.1 25 88.7 25 3.2 0 6.1-1.9 7.3-4.8 1.3-2.9.7-6.3-1.5-8.7-.3-.3-22.4-24.2-35.8-54.5z"></path></svg><span class="vf-counter vf-widget font_gibson font_semibold" data-widget="counter"></span></a></div></div></div><p class="Text__BaseText-mmkwcw-0 gzxeXn"><strong>LOS ANGELES</strong> – Peter Mark Richman, a character actor who appeared in hundreds of television episodes and had recurring roles on “Three's Company" and “Beverly Hills 90210," has died. He was 93.</p><p class="Text__BaseText-mmkwcw-0 gzxeXn">Richman died Thursday at his home in the Woodland Hills area of Los Angeles of natural causes, publicist Harlan Boll announced.</p><p class="Text__BaseText-mmkwcw-0 gzxeXn">Born in Philadelphia, Richman was a pharmacist but turned to acting. He joined the Actors Studio and in 1953 he starred on stage in the play “End as a Man." He appeared on Broadway in “A Hatful of Rain” and “Masquerade.” He also portrayed Jerry in more than 400 New York performances of Edward Albee’s “The Zoo Story," Boll said.</p><p class="Text__BaseText-mmkwcw-0 gzxeXn">His moves included 1958's “The Black Orchid” with Sophia Loren, “The Strange One,” “The Naked Gun 2 1/2: The Smell of Fear” and “Friday the 13th, Part 8.”</p><p class="Text__BaseText-mmkwcw-0 gzxeXn">Bu he was best known for his TV work, appearing in more than 500 episodes of various shows over a decades-long career, from “Bonanza” and “The Fugitive" to ”Star Trek: The Next Generation.”</p><p class="Text__BaseText-mmkwcw-0 gzxeXn">He starred as lawyer Nick Cain in the short-lived 1960′s NBC series “Cain’s Hundred” and had recurring roles as an attorney on the 1980s hit “Dynasty” and the 1970's show “Longstreet."</p><p class="Text__BaseText-mmkwcw-0 gzxeXn">In the 1970s and 1980s he was Suzanne Somers’ father, the Rev. Luther Snow, on ”Three’s Company,” appeared as Lawrence Carson in a few episodes of “Beverly Hills, 90210" and was C.C. Capwell for nearly 30 episodes of “Santa Barbara."</p><p class="Text__BaseText-mmkwcw-0 gzxeXn">Richman also wrote plays, including the acclaimed “4 Faces,” a novel, short stories and an autobiography.</p><p class="Text__BaseText-mmkwcw-0 gzxeXn">In 1990, he received the Silver Medallion from the Motion Picture & Television Fund for outstanding humanitarian achievement. </p><p class="Text__BaseText-mmkwcw-0 gzxeXn">Richman is survived by his wife, Helen, five children and six grandchildren.</p></section><p class="Text__BaseText-mmkwcw-0 iJyOox copyright">Copyright 2021 The Associated Press. All rights reserved. This material may not be published, broadcast, rewritten or redistributed without permission.</p><hr class="Divider-sc-1n9x3vv-0 dCEVY"/></div></article><div class="scGrid full-width oneCol" id="0fI31iIuLro"></div><div id="fusion-static-enter:0fXGD71iDr1" style="display:none"></div><div id="comments"><div id="gmgComments" class="viafoura" style="font-family:&quot;Gibson&quot;, sans-serif"><div id="gmg-vf-page-comments" class="vf-comments vf-widget" data-widget="comments" data-unique-id="5bf289dc6f0a8cafe0cd02c730c1a819"></div></div></div><div id="fusion-static-exit:0fXGD71iDr1" style="display:none"></div></section><section class="bottom-wide"><section class="sponsored-content mb-xlg"><div class="content-block double mb-xlg"><div class="sponsored-content"><section class="content-block"><div id="gmg-outbrain-container"><div class="OUTBRAIN" data-src="https://www.clickorlando.com/entertainment/2021/01/15/noted-character-actor-peter-mark-richman-dies-at-93/" data-widget-id="AR_3" data-ob-template="clickorlando.com"></div></div></section></div></div><div class="content-block mb-xlg"><div class="sponsored-content"><section class="content-block"><div id="gmg-outbrain-container"><div class="OUTBRAIN" data-src="https://www.clickorlando.com/entertainment/2021/01/15/noted-character-actor-peter-mark-richman-dies-at-93/" data-widget-id="AR_4" data-ob-template="clickorlando.com"></div></div></section></div></div><div class="content-block mb-xlg"></div></section></section></main></section><footer class="font_gibson color_black width_full"><div id="fusion-static-enter:0fH6IRQdGrW" style="display:none"></div><div class="linkWrap box_content display_flex mCenter width_max" style="margin-bottom:2.5rem"><ul class="display_grid gap_x_lg gap_y_med no-margin width_full"><li class="font_regular"><a href="https://www.clickorlando.com/tv-listings/">TV Listings</a></li><li class="font_regular"><a href="https://www.clickorlando.com/contests/">Contests and Rules</a></li><li class="font_regular"><a href="https://www.clickorlando.com/account/newsletters/">Email Newsletters</a></li><li class="font_regular"><a href="https://www.clickorlando.com/rss/">RSS Feeds</a></li><li class="font_regular"><a href="https://www.clickorlando.com/news/2019/11/11/closed-captioning-information/">Closed Captioning</a></li><li class="font_regular"><a href="https://www.clickorlando.com/contact/">Contact Us / Follow on Social Media</a></li><li class="font_regular"><a href="https://www.clickorlando.com/careers/">Careers at WKMG</a></li><li class="font_regular"><a href="https://www.clickorlando.com/station/2019/11/11/terms-of-use/">Terms of Use</a></li><li class="font_regular"><a href="https://www.clickorlando.com/station/2019/11/11/privacy-policy/">Privacy Policy</a></li><li class="font_regular"><a href="https://www.clickorlando.com/station/2019/11/11/online-public-inspection-file/">Public File</a></li><li class="font_regular"><a href="https://publicfiles.fcc.gov/tv-profile/wkmg-tv/equal-employment-opportunity-records/additional-documents/eeo-public-file-reports/723baae8-a5cf-e194-3c58-210aa23225d5/">EEO Report</a></li><li class="font_regular"><a href="https://www.clickorlando.com/station/2019/11/11/online-public-inspection-file/">Disability Assistance</a></li><li class="font_regular"><a href="/usprivacy/">Do Not Sell My Info</a></li></ul><div class="followUs display_flex justify_space_between mb-xlg "><div class="social"><h6 class="color_black uppercase" style="letter-spacing:0.05em">Follow Us</h6><div class="icons display_flex"><a class="color_black gaevent" href="https://www.facebook.com/news6/" gacategory="Nav" gaaction="Footer Social" galabel="https://www.facebook.com/news6/"><svg aria-labelledby="svg-inline--fa-title-JyenYZJoLAhU" data-prefix="fab" data-icon="facebook-f" class="svg-inline--fa fa-facebook-f fa-w-10 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 320 512"><title id="svg-inline--fa-title-JyenYZJoLAhU">facebook</title><path fill="currentColor" d="M279.14 288l14.22-92.66h-88.91v-60.13c0-25.35 12.42-50.06 52.24-50.06h40.42V6.26S260.43 0 225.36 0c-73.22 0-121.08 44.38-121.08 124.72v70.62H22.89V288h81.39v224h100.17V288z"></path></svg></a><a class="color_black gaevent" href="https://twitter.com/news6wkmg/" gacategory="Nav" gaaction="Footer Social" galabel="https://twitter.com/news6wkmg/"><svg aria-labelledby="svg-inline--fa-title-4hP6UOiDNBvI" data-prefix="fab" data-icon="twitter" class="svg-inline--fa fa-twitter fa-w-16 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><title id="svg-inline--fa-title-4hP6UOiDNBvI">twitter</title><path fill="currentColor" d="M459.37 151.716c.325 4.548.325 9.097.325 13.645 0 138.72-105.583 298.558-298.558 298.558-59.452 0-114.68-17.219-161.137-47.106 8.447.974 16.568 1.299 25.34 1.299 49.055 0 94.213-16.568 130.274-44.832-46.132-.975-84.792-31.188-98.112-72.772 6.498.974 12.995 1.624 19.818 1.624 9.421 0 18.843-1.3 27.614-3.573-48.081-9.747-84.143-51.98-84.143-102.985v-1.299c13.969 7.797 30.214 12.67 47.431 13.319-28.264-18.843-46.781-51.005-46.781-87.391 0-19.492 5.197-37.36 14.294-52.954 51.655 63.675 129.3 105.258 216.365 109.807-1.624-7.797-2.599-15.918-2.599-24.04 0-57.828 46.782-104.934 104.934-104.934 30.213 0 57.502 12.67 76.67 33.137 23.715-4.548 46.456-13.32 66.599-25.34-7.798 24.366-24.366 44.833-46.132 57.827 21.117-2.273 41.584-8.122 60.426-16.243-14.292 20.791-32.161 39.308-52.628 54.253z"></path></svg></a><a class="color_black gaevent" href="https://www.instagram.com/news6wkmg/" gacategory="Nav" gaaction="Footer Social" galabel="https://www.instagram.com/news6wkmg/"><svg aria-labelledby="svg-inline--fa-title-XYwXmGFVG0BM" data-prefix="fab" data-icon="instagram" class="svg-inline--fa fa-instagram fa-w-14 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><title id="svg-inline--fa-title-XYwXmGFVG0BM">instagram</title><path fill="currentColor" d="M224.1 141c-63.6 0-114.9 51.3-114.9 114.9s51.3 114.9 114.9 114.9S339 319.5 339 255.9 287.7 141 224.1 141zm0 189.6c-41.1 0-74.7-33.5-74.7-74.7s33.5-74.7 74.7-74.7 74.7 33.5 74.7 74.7-33.6 74.7-74.7 74.7zm146.4-194.3c0 14.9-12 26.8-26.8 26.8-14.9 0-26.8-12-26.8-26.8s12-26.8 26.8-26.8 26.8 12 26.8 26.8zm76.1 27.2c-1.7-35.9-9.9-67.7-36.2-93.9-26.2-26.2-58-34.4-93.9-36.2-37-2.1-147.9-2.1-184.9 0-35.8 1.7-67.6 9.9-93.9 36.1s-34.4 58-36.2 93.9c-2.1 37-2.1 147.9 0 184.9 1.7 35.9 9.9 67.7 36.2 93.9s58 34.4 93.9 36.2c37 2.1 147.9 2.1 184.9 0 35.9-1.7 67.7-9.9 93.9-36.2 26.2-26.2 34.4-58 36.2-93.9 2.1-37 2.1-147.8 0-184.8zM398.8 388c-7.8 19.6-22.9 34.7-42.6 42.6-29.5 11.7-99.5 9-132.1 9s-102.7 2.6-132.1-9c-19.6-7.8-34.7-22.9-42.6-42.6-11.7-29.5-9-99.5-9-132.1s-2.6-102.7 9-132.1c7.8-19.6 22.9-34.7 42.6-42.6 29.5-11.7 99.5-9 132.1-9s102.7-2.6 132.1 9c19.6 7.8 34.7 22.9 42.6 42.6 11.7 29.5 9 99.5 9 132.1s2.7 102.7-9 132.1z"></path></svg></a><a class="color_black gaevent" href="https://www.clickorlando.com/rss/" gacategory="Nav" gaaction="Footer Social" galabel="https://www.clickorlando.com/rss/"><svg aria-labelledby="svg-inline--fa-title-nF5vCoQdvm65" data-prefix="fas" data-icon="rss" class="svg-inline--fa fa-rss fa-w-14 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><title id="svg-inline--fa-title-nF5vCoQdvm65">rss</title><path fill="currentColor" d="M128.081 415.959c0 35.369-28.672 64.041-64.041 64.041S0 451.328 0 415.959s28.672-64.041 64.041-64.041 64.04 28.673 64.04 64.041zm175.66 47.25c-8.354-154.6-132.185-278.587-286.95-286.95C7.656 175.765 0 183.105 0 192.253v48.069c0 8.415 6.49 15.472 14.887 16.018 111.832 7.284 201.473 96.702 208.772 208.772.547 8.397 7.604 14.887 16.018 14.887h48.069c9.149.001 16.489-7.655 15.995-16.79zm144.249.288C439.596 229.677 251.465 40.445 16.503 32.01 7.473 31.686 0 38.981 0 48.016v48.068c0 8.625 6.835 15.645 15.453 15.999 191.179 7.839 344.627 161.316 352.465 352.465.353 8.618 7.373 15.453 15.999 15.453h48.068c9.034-.001 16.329-7.474 16.005-16.504z"></path></svg></a></div></div><div class="omne"><h6 class="color_black uppercase">Get Results with Omne</h6><a href="https://omneresults.com/" target="_blank" rel="noreferrer"><figure class="Box-sc-12ejyki-0 kaPImw relative"><div class="Box-sc-12ejyki-0 bWgAyd"><img src="/pf/resources/images/shared/placeholder.svg?d=238" style="object-fit:cover;position:absolute;top:0;right:0;bottom:0;left:0;width:100%;height:100%" alt="Omne Results Logo"/></div></figure></a></div></div></div><p class="no-margin color_black box_content width_max mCenter" style="margin-bottom:3rem;padding:0 1.5rem">If you need help with the Public File, call 407-291-6000.</p><div class="corporate box_content mCenter width_max"><hr class="width_full regular" style="margin-bottom:3rem"/><div class="display_flex align_items_center width_max"><div class="logos display_flex mb-med"><a href="https://www.grahammedia.com/" target="_blank" rel="noreferrer"><img src="https://www.clickondetroit.com/static-resources/shared/images/gmg_dark.svg" alt="Graham Media Group Logo"/></a><a href="https://hello.grahamdigital.com/" target="_blank" rel="noreferrer"><img src="https://www.clickondetroit.com/static-resources/shared/images/gd_dark.svg" alt="Graham Digital Logo"/></a></div><div class="copyright color_black"><span>Copyright © </span>2021<!-- --> <!-- -->ClickOrlando.com<!-- --> <!-- -->is managed by Graham Digital and pubished by Graham Media Group, a division of Graham Holdings.</div></div></div><div id="fusion-static-exit:0fH6IRQdGrW" style="display:none"></div></footer></div><script id="fusion-template-script" type="application/javascript" src="/pf/dist/template/article/default.js?d=238" defer=""></script><script type="application/javascript">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</script><iframe name="__uspapiLocator" style="display:none" title="__uspapilocator"></iframe><script type="text/javascript" async="" src="//cdn.viafoura.net/vf-v2.js"></script><script src="https://ak.sail-horizon.com/spm/spm.v1.min.js"></script></body></html>