<!DOCTYPE html><html lang="en"><head><meta charset="utf-8"/><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no"/><link rel="canonical" href="https://www.clickorlando.com/news/local/2021/06/22/street-next-to-roberto-clemente-middle-school-in-orlando-gets-new-name/"/><link rel="amphtml" href="https://www.clickorlando.com/news/local/2021/06/22/street-next-to-roberto-clemente-middle-school-in-orlando-gets-new-name/?outputType=amp"/><title>Street next to Roberto Clemente Middle School in Orlando gets new name</title><link rel="dns-prefetch" href="graham-wkmg.zeustechnology.com"/><link rel="dns-prefetch" href="securepubads.g.doubleclick.net"/><link rel="dns-prefetch" href="static.doubleclick.net"/><link rel="dns-prefetch" href="ib.adnxs.com"/><link rel="dns-prefetch" href="bidder.criteo.com"/><link rel="dns-prefetch" href="static.criteo.net"/><link rel="dns-prefetch" href="as-sec.casalemedia.com"/><link rel="dns-prefetch" href="js-sec.indexww.com"/><link rel="dns-prefetch" href="graham-d.openx.net"/><link rel="dns-prefetch" href="hbopenbid.pubmatic.com"/><link rel="dns-prefetch" href="fastlane.rubiconproject.com"/><link rel="dns-prefetch" href="ap.lijit.com"/><link rel="dns-prefetch" href="s.amazon-adsystem.com"/><link rel="dns-prefetch" href="tagan.adlightning.com"/><link rel="dns-prefetch" href="tpc.googlesyndication.com"/><link rel="dns-prefetch" href="www.googletagservices.com"/><link rel="dns-prefetch" href="fonts.googleapis.com"/><link rel="dns-prefetch" href="cdn.viafoura.net"/><link rel="dns-prefetch" href="ak.sail-horizon.com"/><link rel="dns-prefetch" href="wkmg-live.gmg.io"/><link rel="dns-prefetch" href="grahammedia.blueconic.net"/><link rel="preload" href="https://www.clickorlando.com/resizer/2O6dggXfGmt5fGYwD193j4js2Xs=/800x450/smart/filters:format(jpeg):strip_exif(true):strip_icc(true):no_upscale(true):quality(65):fill(FFF)/cloudfront-us-east-1.images.arcpublishing.com/gmg/SBLQ6DJ2Z5BB7MXPRU3EUUL7EY.jpg" as="image" type="image/jpeg"/><link rel="preload" href="/pf/resources/fonts/Gibson/Gibson-Light.woff?d=311" as="font" type="font/woff" crossorigin="anonymous"/><link rel="preload" href="/pf/resources/fonts/Gibson/Gibson-Regular.woff?d=311" as="font" type="font/woff" crossorigin="anonymous"/><link rel="preload" href="/pf/resources/fonts/Gibson/Gibson-Italic.woff?d=311" as="font" type="font/woff" crossorigin="anonymous"/><link rel="preload" href="/pf/resources/fonts/Gibson/Gibson-Medium.woff?d=311" as="font" type="font/woff" crossorigin="anonymous"/><link rel="preload" href="/pf/resources/fonts/Gibson/Gibson-SemiBold.woff?d=311" as="font" type="font/woff" crossorigin="anonymous"/><link rel="preload" href="/pf/resources/fonts/Gibson/Gibson-Bold.woff?d=311" as="font" type="font/woff" crossorigin="anonymous"/><link rel="preload" href="/pf/resources/fonts/Gibson/Gibson-BoldItalic.woff?d=311" as="font" type="font/woff" crossorigin="anonymous"/><link rel="preload" href="/pf/resources/fonts/OpenSans/OpenSans-Regular.woff?d=311" as="font" type="font/woff" crossorigin="anonymous"/><link rel="preload" href="/pf/resources/fonts/OpenSans/OpenSans-RegularItalic.woff?d=311" as="font" type="font/woff" crossorigin="anonymous"/><link rel="preload" href="/pf/resources/fonts/OpenSans/OpenSans-Bold.woff?d=311" as="font" type="font/woff" crossorigin="anonymous"/><link rel="preload" href="/pf/resources/fonts/OpenSans/OpenSans-ExtraBold.woff?d=311" as="font" type="font/woff" crossorigin="anonymous"/><style>@font-face{font-family:"Gibson";font-display:swap;src:url(/pf/resources/fonts/Gibson/Gibson-Light.woff?d=311) format("woff");font-weight:200;font-style:normal;font-stretch: wider}@font-face{font-family:"Gibson";font-display:swap;src:url(/pf/resources/fonts/Gibson/Gibson-Regular.woff?d=311) format("woff");font-weight:400;font-style:normal;font-stretch: normal}@font-face{font-family:"Gibson";font-display:swap;src:url(/pf/resources/fonts/Gibson/Gibson-Italic.woff?d=311) format("woff");font-weight:400;font-style:italic;font-stretch: normal}@font-face{font-family:"Gibson";font-display:swap;src:url(/pf/resources/fonts/Gibson/Gibson-Medium.woff?d=311) format("woff");font-weight:500;font-style:normal;font-stretch: normal}@font-face{font-family:"Gibson";font-display:swap;src:url(/pf/resources/fonts/Gibson/Gibson-SemiBold.woff?d=311) format("woff");font-weight:600;font-style:normal;font-stretch: normal}@font-face{font-family:"Gibson";font-display:swap;src:url(/pf/resources/fonts/Gibson/Gibson-Bold.woff?d=311) format("woff");font-weight:700;font-style:normal;font-stretch: normal}@font-face{font-family:"Gibson";font-display:swap;src:url(/pf/resources/fonts/Gibson/Gibson-BoldItalic.woff?d=311) format("woff");font-weight:700;font-style:italic;font-stretch: normal}@font-face{font-family:"OpenSans";font-display:swap;src:url(/pf/resources/fonts/OpenSans/OpenSans-Regular.woff?d=311) format("woff");font-weight:400;font-style:normal;font-stretch: normal}@font-face{font-family:"OpenSans";font-display:swap;src:url(/pf/resources/fonts/OpenSans/OpenSans-RegularItalic.woff?d=311) format("woff");font-weight:400;font-style:italic;font-stretch: normal}@font-face{font-family:"OpenSans";font-display:swap;src:url(/pf/resources/fonts/OpenSans/OpenSans-Bold.woff?d=311) format("woff");font-weight:700;font-style:normal;font-stretch: normal}@font-face{font-family:"OpenSans";font-display:swap;src:url(/pf/resources/fonts/OpenSans/OpenSans-ExtraBold.woff?d=311) format("woff");font-weight:900;font-style:normal;font-stretch: normal}</style><meta property="og:url" content="https://www.clickorlando.com/news/local/2021/06/22/street-next-to-roberto-clemente-middle-school-in-orlando-gets-new-name/"/><meta property="og:title" content="Street next to Roberto Clemente Middle School in Orlando gets new name"/><meta property="og:type" content="article"/><meta property="og:description" content="The street where the school sits will officially be renamed Roberto Clemente Road during a ceremony Wednesday."/><meta property="og:image" content="https://www.clickorlando.com/resizer/2O6dggXfGmt5fGYwD193j4js2Xs=/800x450/smart/filters:format(jpeg):strip_exif(true):strip_icc(true):no_upscale(true):quality(65):fill(FFF)/cloudfront-us-east-1.images.arcpublishing.com/gmg/SBLQ6DJ2Z5BB7MXPRU3EUUL7EY.jpg"/><meta property="og:site_name" content="WKMG"/><meta property="og:locale" content="en_US"/><meta property="article:published_time" content="2021-06-22T14:18:53.365Z"/><meta property="article:modified_time" content="2021-06-22T14:18:55.026Z"/><meta property="article:section" content="Local News"/><meta property="article:tag" content="Orlando,Orange County,Roberto Clemente"/><meta property="article:content_tier" content="free"/><meta property="article:opinion" content="false"/><meta name="type" value="article"/><meta name="keywords" content="Orlando,Orange County,Roberto Clemente"/><meta name="content_id" content="JL4ZRIGGJNFLHAUD7A6L5XQA6E"/><meta name="author" content="Emilee Speck"/><meta name="description" content="The street where the school sits will officially be renamed Roberto Clemente Road during a ceremony Wednesday."/><meta name="section_path" content="/news/local"/><meta name="station" content="WKMG"/><meta name="line_count"/><meta name="word_count"/><meta name="inch_count"/><meta name="sailthru.author" content="Emilee Speck"/><meta name="sailthru.title" content="Street next to Roberto Clemente Middle School in Orlando gets new name"/><meta name="sailthru.description" content="The street where the school sits will officially be renamed Roberto Clemente Road during a ceremony Wednesday."/><meta name="sailthru.tags" content="Orlando,Orange County,Roberto Clemente"/><meta name="sailthru.date" content="2021-06-22T14:18:55.026Z"/><meta name="sailthru.image.full" content="https://www.clickorlando.com/resizer/2O6dggXfGmt5fGYwD193j4js2Xs=/800x450/smart/filters:format(jpeg):strip_exif(true):strip_icc(true):no_upscale(true):quality(65):fill(FFF)/cloudfront-us-east-1.images.arcpublishing.com/gmg/SBLQ6DJ2Z5BB7MXPRU3EUUL7EY.jpg"/><meta name="sailthru.image.thumb" content="https://www.clickorlando.com/resizer/3q2U7rOI6EFAQPveTFsIgBEBajg=/96x54/smart/filters:format(jpeg):strip_exif(true):strip_icc(true):no_upscale(true):quality(65):fill(FFF)/cloudfront-us-east-1.images.arcpublishing.com/gmg/SBLQ6DJ2Z5BB7MXPRU3EUUL7EY.jpg"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:title" content="Street next to Roberto Clemente Middle School in Orlando gets new name"/><meta name="twitter:description" content="The street where the school sits will officially be renamed Roberto Clemente Road during a ceremony Wednesday."/><meta name="twitter:site" content="WKMG"/><meta name="twitter:image" content="https://www.clickorlando.com/resizer/2O6dggXfGmt5fGYwD193j4js2Xs=/800x450/smart/filters:format(jpeg):strip_exif(true):strip_icc(true):no_upscale(true):quality(65):fill(FFF)/cloudfront-us-east-1.images.arcpublishing.com/gmg/SBLQ6DJ2Z5BB7MXPRU3EUUL7EY.jpg"/><meta name="twitter:domain" content="https://www.clickorlando.com"/><meta property="fb:app_id" content="398048186916440"/><meta name="vf:unique_id" content="JL4ZRIGGJNFLHAUD7A6L5XQA6E"/><meta property="al:ios:url"/><meta property="al:ios:app_store_id" content="426128464"/><meta property="al:ios:app_name" content="clickorlando.com"/><meta property="al:android:url"/><meta property="al:android:package" content="com.ibsys.app.pns_orlpn"/><meta property="al:android:app_name" content="clickorlando.com"/><meta name="vf:topic" content="ORLANDO"/><meta name="vf:topic" content="ORANGE COUNTY"/><meta name="vf:topic" content="ROBERTO CLEMENTE"/><script src="https://profiles.clickorlando.com/script.js" async=""></script><link rel="manifest" href="/manifest.json"/><style>.async-hide { opacity: 0 !important}</style><script>(function(a,s,y,n,c,h,i,d,e){s.className+=' '+y;h.start=1*new Date;
    h.end=i=function(){s.className=s.className.replace(RegExp(' ?'+y),'')};
    (a[n]=a[n]||[]).hide=h;setTimeout(function(){i();h.end=null},c);h.timeout=c;
    })(window,document.documentElement,'async-hide','dataLayer',4000,
    {'GTM-MG7SZLK':true});</script><script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
    ga('create', 'UA-17717614-1', 'auto', {'useAmpClientId':true});
    ga('require', 'GTM-MG7SZLK');</script><script async="" src="https://www.googletagmanager.com/gtm/js?id=GTM-NQDG22W"></script><script>if (window) { window.dataLayer = window.dataLayer || [];
    window.dataLayer.push(
      {"siteId": "WKMG",
      'event':'gtm.js'
      }
    )}</script><script type="application/ld+json">{"@context":"https://schema.org","@type":"Article","headline":"Street next to Roberto Clemente Middle School in Orlando gets new name","description":"The street where the school sits will officially be renamed Roberto Clemente Road during a ceremony Wednesday.","url":"https://www.clickorlando.com/news/local/2021/06/22/street-next-to-roberto-clemente-middle-school-in-orlando-gets-new-name/","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.clickorlando.com/news/local/2021/06/22/street-next-to-roberto-clemente-middle-school-in-orlando-gets-new-name/"},"image":{"@type":"ImageObject","url":"https://www.clickorlando.com/resizer/3q2U7rOI6EFAQPveTFsIgBEBajg=/96x54/smart/filters:format(jpeg):strip_exif(true):strip_icc(true):no_upscale(true):quality(65):fill(FFF)/cloudfront-us-east-1.images.arcpublishing.com/gmg/SBLQ6DJ2Z5BB7MXPRU3EUUL7EY.jpg","name":"Central Florida artist creates mural for Roberto Clemente Middle School","width":300,"height":168},"datePublished":"2021-06-22T14:18:53.365Z","dateModified":"2021-06-22T14:18:55.026Z","publisher":{"@type":"Organization","name":"WKMG News 6 & ClickOrlando","logo":{"@type":"ImageObject","url":"https://t.gmg.io/amp/search/wkmg.png","name":"WKMG News 6 & ClickOrlando.com"}},"author":[{"@type":"Person","name":"Emilee Speck","sameAs":"https://www.clickorlando.com/team/XZOBO4D3XFHHVKRORQRC5OKNUM"}],"articleSection":"Local News","mentions":[{"@type":"Thing","name":"Orlando","url":"https://www.clickorlando.com/topic/Orlando/"},{"@type":"Thing","name":"Orange County","url":"https://www.clickorlando.com/topic/Orange_County/"},{"@type":"Thing","name":"Roberto Clemente","url":"https://www.clickorlando.com/topic/Roberto_Clemente/"}],"keywords":["Orlando","Orange County","Roberto Clemente"]}</script><link rel="preload" href="/pf/resources/dist/wkmg/js/index.js?d=311" as="script"/><script src="/pf/resources/dist/wkmg/js/index.js?d=311" async=""></script><link rel="preload" href="/pf/resources/dist/wkmg/css/style.css?d=311" as="style"/><link rel="preload" href="/pf/dist/components/combinations/default.js?d=311" as="script"/><link rel="stylesheet" href="/pf/resources/dist/wkmg/css/style.css?d=311"/><link rel="icon" type="image/x-icon" href="/pf/resources/images/wkmg/favicon.ico?d=311"/><meta name="coid" content="JL4ZRIGGJNFLHAUD7A6L5XQA6E"/><meta name="type" content="article"/><script type="application/javascript" id="polyfill-script">if(!Array.prototype.includes||!(window.Object && window.Object.assign)||!window.Promise||!window.Symbol||!window.fetch){document.write('<script type="application/javascript" src="/pf/dist/engine/polyfill.js?d=311" defer=""><\/script>')}</script><script id="fusion-engine-react-script" type="application/javascript" src="/pf/dist/engine/react.js?d=311" defer=""></script><script id="fusion-engine-combinations-script" type="application/javascript" src="/pf/dist/components/combinations/default.js?d=311" defer=""></script><link id="fusion-template-styles" rel="stylesheet" type="text/css"/><style data-styled="dZjReU fSHFbF gKfpUK jFLeST lcFans NUNlW kckMfq dHOSwd fiekws fwZqtV YdQgG clvcNz giSDva kQEYap eRZcpD iYnEts kqxPWZ gfTpEa nqHSn jJYKhZ dOIBOU cTWEtd gueTsy fDULNQ hiRkNr cLGXPz fECuNw edjlNO bAtFBP cbWPlM TXBN gXpKOb ecExAQ liazok IxIhx khswYN jCEkSM kxdhCj bdrOSW kVhudR gFRVtH gUBsGz kyDAOn sWctw ecuNbI jFgmSC kvtnlw fFWmJ dRMzTN gAsKeO cxvGvt KtFsv jjPXWi iRIfME kcEFxM icxcVO ernmxz guuoai dxLtzo ldlkLX dchGiv fmbrWI JGBpd cXIylP kVPDul fejUQY kilsRi jdfoAV leOKfn hkOvmC bdblZq kzFnFX cZxrFf gvkeHj kaPImw geIAAj jdBinm tEfJj hJxlgt hnikHe jfrLJo eWxIgu vWBZS dQMpyt hUCeMK kZgoCE eMmBBi caFKJk bZGwFC ewQCSW gQHKfs cItYXk hKogbc dyJgJw etKPQM kfVJEM dgJeyJ deAfkq jLFMlX jXmjsZ btgytX jNTfAT kBdchC hAfQFP fkPfnZ fZUdyo fSJjpK cSwJGE kDWdaE lcXlHy elOndi elybIm djyEOW hdyfKU iOFNJi eublBW htbuJv fREajg gnYyAK fQqqzz ETmNp bsHRFG hQbBpf dgPHLS cIBWdg khwpRN fPYIGV iYuUJm gYLfnR cxHMZc FTPkm dfchQM elRaHF eRVpMB dQNexQ eUYHPS ghjhZl hTpoqt fJxCWQ ehfZJW glXEHH hVgEyq hZkuHu xsRcK fKQiGd gcJurz eUxQdE hifqJT cLDMtd ebQViL kTQatP iWZSgl feNIHh cOJUZB jKvIth EdvZS hcOtrz jiumXl bjeGDy kpKuDD lenvlz leJHKp hCJDUj kvTtQB jgiPBb brEKjv jhlsYP hFChmX dhCPIc hwnqvo fHqRNB kIrSAy brbVvm ckEYuP ekrcBh SMBny khKvJG dbKhyo iSRWqd emWdvo jbyLNc jcSBbU dUNnwz fHPrAR iVNNhU ldtmQG eGIiXs dDeamZ dpuivR ifTxbm emdtaN uaLOR bXLUxr ciugoX eTAIBb cYyZvG iKuSZp QZNSw kBmDLj fLgRBc eAzbIG dSOlzQ gqqRuu tzeei fIxjgD kjNniI irEEaG jeDXwL bCgwSc cWpTbe eulNUh hObaso loEktu bMpCDl bgiycj fJpLJR fLEDfG iLJAuF cGFgHT efLRKi fdOGcB faMlgr bgpVcv ecwFvf eayAjN dUdVZO iCCVDB hInUhl cFCdPb hnyrsL fMsqtl jYXlHP eoprv MWZoW bglNmn iLdRDx eXrxTa dSzQps jscHqD iBBesh crlqeP gDDbEP eQXGyy cvhWkg cIJupy dBrTEe cjADrz fnvXgm kOzcqf fmNCdr cPdTHN iECcOk iwiQoU dHFVYU IkOoR ldVZj bJaBgm dnQLDO OTuhu dRQnSc jkKnRX cdGQRY guafWb cxcHBB cviPwu fEMfKg jWHIcH fryNVZ eOOQUP kVCsSp kqjyrw eHDzxX catVTY kSYypd hyNOaF fIErcc hqPcbw kXwdaZ jnViHN efYXdJ dDYPrs HrbVJ pbtUU bHWzNn eijlGq dJuWiv efNyj khlKXP frNGhP eJRilf frWjXu hLkLrx hTqPlS eBRlta gIzSgu eWLGCT kiEpJN jJnjDF eDCJmp fhKfXJ lohLPY dlnJrb jZyACL haoJbT eJuIOy" data-styled-version="4.4.1">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</style><script src="https://tagan.adlightning.com/grahammedia/op.js" defer=""></script><script src="https://c.amazon-adsystem.com/aax2/apstag.js" async=""></script><script>
    window.gmgAdUnitPath = "/15466288/WKMG/Web/news/local";
    window.zeusKeyvalues = {
      tags: "orlando,orange county,roberto clemente",
      type: "article",
      coid: "JL4ZRIGGJNFLHAUD7A6L5XQA6E"
    };
  </script><script src="https://graham-WKMG.zeustechnology.com/main.js" async="" id="__zeus_script"></script><script>
    window.BlueconicEnabled = true;
    window.ArcPOptions = {
        paywallFunction: function(campaign) {
          if (!document.location.pathname.endsWith(campaign.split("?")[0])) {
            dataLayer.push({
              "event": "ArcSubsPaywall",
              "paywall_action": "blocked",
              "paywall_campaign": campaign
            });
            document.location = campaign + (campaign.indexOf("?") === -1 ? "?" : "&") + "ref=" + document.location.pathname;
          }
        },
        contentType: "article",
        section: "/news/local",
        contentRestriction: "no_restrictions",
        resultsCallback: function(results) {
          console.dir(results);
        },
        apiOrigin: "api-gmg-wkmg-prod.cdn.arcpublishing.com"
    };
  </script><script src="/arc/subs/p.js" async=""></script>
  <script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"true","rua.upre":"true","rua.cpre":"true","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-6c8b4ca4-80b7-4d41-beb2-b575a0d0b06e","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false","rua.isuxp":"false","rua.texp":"norulematch"}]);</script>
                          <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="SCEDS-P5UYQ-92N2P-RUTAN-BL3R9",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"SCEDS-P5UYQ-92N2P-RUTAN-BL3R9",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e="true"=="true"?1:0,t="",n="nml5ubax2t5fmygsaqla-f-ac411994b-clientnsv4-s.akamaihd.net",i={"ak.v":"31","ak.cp":"890254","ak.ai":parseInt("569011",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"29a8c83c","ak.r":41490,"ak.a2":e,"ak.m":"a","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":50844,"ak.gh":"23.220.106.86","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1624376342","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==U5J0YnOu6rnTFJl164ofRnVxpzwjdOpyEjXKbcLLAPElzbttge7shwmUD0CfVXh3u040V5L1VQtuJ3WchzieHMueKsACrytQ4QGe7MUX+ckPZUkBXndCJJnYY0LpmmEwKiN2GTigP4TubRtIsnJa8ApzZzKwGA1dW5kWsWv7cxc1Vd1AYpzVmNAaUy7VNYSuMdhjK8ytzCLees4CABsJiYAQhChcsXdHyWqy21dW9DGU47jsj0bsi+rsBgPkTNgS0FXmJJykMq2dGpRJ8Gaj63Lxuw3K3DGSwkecYdxfFyYlPxLBMdg6B6INNft0uFkfUb55g82rYGUUpYlb9yXP/QI7ZRwkL+RPYy2XL8IQOrFzwy1f2/ajRQl/ru1exHoMVbESY7Obrk0cshHNilp+KoY+ASec+EMsfDCMsX6H9ek=","ak.pv":"19","ak.dpoabenc":""};if(""!==t)i["ak.ruds"]=t;var _={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))i["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(i)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:i,akDNSPreFetchDomain:n,init:function(){if(!_.i){var a=BOOMR.subscribe;a("before_beacon",_.av,null,null),a("onbeacon",_.rv,null,null),_.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head><body class="" data-station="wkmg"><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NQDG22W" height="0" width="0" style="display:none;visibility:hidden" title="GTM"></iframe></noscript><div id="fusion-app"><header class="Box-sc-12ejyki-0 gvkeHj"><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 eRZcpD headerWrapper"><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 iYnEts container"><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 kqxPWZ left"><div class="Box-sc-12ejyki-0 fLgRBc pointer"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="bars" class="svg-inline--fa fa-bars fa-w-14 fa-fw " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M16 132h416c8.837 0 16-7.163 16-16V76c0-8.837-7.163-16-16-16H16C7.163 60 0 67.163 0 76v40c0 8.837 7.163 16 16 16zm0 160h416c8.837 0 16-7.163 16-16v-40c0-8.837-7.163-16-16-16H16c-8.837 0-16 7.163-16 16v40c0 8.837 7.163 16 16 16zm0 160h416c8.837 0 16-7.163 16-16v-40c0-8.837-7.163-16-16-16H16c-8.837 0-16 7.163-16 16v40c0 8.837 7.163 16 16 16z"></path></svg></div><a href="/weather/" class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 dOIBOU weather"><figure class="Box-sc-12ejyki-0 eulNUh"><div class="Box-sc-12ejyki-0 cOJUZB imageWrapper"><img class="Box-sc-12ejyki-0 kaPImw" decoding="async" src="https://t.gmg.io/weather/widgets/34.svg" alt="Partly Cloudy icon"/></div></figure><div class="Box-sc-12ejyki-0 hObaso"><span class="Text__BaseText-mmkwcw-0 kxdhCj">84<span class="Text__BaseText-mmkwcw-0 kxdhCj">º</span></span></div></a></div><div class="Box-sc-12ejyki-0 eAzbIG logo gaevent"><a href="/" gacategory="Nav" gaaction="Home" galabel="/"><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 gfTpEa logoCard"><div class="Box-sc-12ejyki-0 dSOlzQ front face"></div><div class="Box-sc-12ejyki-0 gqqRuu back face"></div></div></a></div><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 nqHSn right"><div class="Box-sc-12ejyki-0 tzeei"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="user" class="svg-inline--fa fa-user fa-w-14 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M224 256c70.7 0 128-57.3 128-128S294.7 0 224 0 96 57.3 96 128s57.3 128 128 128zm89.6 32h-16.7c-22.2 10.2-46.9 16-72.9 16s-50.6-5.8-72.9-16h-16.7C60.2 288 0 348.2 0 422.4V464c0 26.5 21.5 48 48 48h352c26.5 0 48-21.5 48-48v-41.6c0-74.2-60.2-134.4-134.4-134.4z"></path></svg></div><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 jJYKhZ"><button class="Box-sc-12ejyki-0 Button__BaseButton-sc-11k3sle-0 efNyj"><span class="Text__BaseText-mmkwcw-0 ecuNbI">Sign In</span><div class="Box-sc-12ejyki-0 fIxjgD"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="user" class="svg-inline--fa fa-user fa-w-14 fa-fw " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M224 256c70.7 0 128-57.3 128-128S294.7 0 224 0 96 57.3 96 128s57.3 128 128 128zm89.6 32h-16.7c-22.2 10.2-46.9 16-72.9 16s-50.6-5.8-72.9-16h-16.7C60.2 288 0 348.2 0 422.4V464c0 26.5 21.5 48 48 48h352c26.5 0 48-21.5 48-48v-41.6c0-74.2-60.2-134.4-134.4-134.4z"></path></svg></div></button></div><div class="viafoura"><vf-tray-trigger floating="false" style="display:none"></vf-tray-trigger></div></div></div></div><div class="Box-sc-12ejyki-0 loEktu burgerMenu transition-100"><div class="Box-sc-12ejyki-0 bMpCDl"><div class="Box-sc-12ejyki-0 bgiycj"><div class="Box-sc-12ejyki-0 fJpLJR"><form action="/search/" class="" id="navSearch" method="get" name="" role="search"><div class="Box-sc-12ejyki-0 fLEDfG inputWrapper"><input type="text" id="navSearchInputBox" name="searchTerm" placeholder="Search for anything..." value="" class="Box-sc-12ejyki-0 Input__BaseInput-qwik9t-0 eJuIOy"/></div><button class="btn font_gibson transition-100 display_none font_semibold blue" name="" type="submit" value="">Search</button></form></div></div><nav class="Box-sc-12ejyki-0 bgiycj navItems"><ul class="Box-sc-12ejyki-0 iLJAuF"><li class="Box-sc-12ejyki-0 cGFgHT primary"><ul class="Box-sc-12ejyki-0 efLRKi secondary"><li class="Box-sc-12ejyki-0 kaPImw parent"><div class="Box-sc-12ejyki-0 fdOGcB gaevent"><a href="/news/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/news">News</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/watch-live/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/watch-live/" gavalue="0">Watch Live</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/news/investigators/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/news/investigators" gavalue="1">Investigators</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/News_6_At_Nine/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/News_6_At_Nine/" gavalue="2">News 6 At Nine</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/news/local/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/news/local" gavalue="3">Local News</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/news/florida/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/news/florida" gavalue="4">Florida</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/news/national/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/news/national" gavalue="5">National</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/news/world/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/news/world" gavalue="6">World</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/news/politics/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/news/politics" gavalue="7">Politics</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Space/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Space/" gavalue="8">Space News</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Trust_Index/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Trust_Index/" gavalue="9">Trust Index</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Coronavirus/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Coronavirus/" gavalue="10">Coronavirus</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Vaccine/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Vaccine/" gavalue="11">Vaccine</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Do_Your_Part/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Do_Your_Part/" gavalue="12">Do Your Part</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/entertainment/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/entertainment" gavalue="13">Entertainment</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Strange_Florida/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Strange_Florida/" gavalue="14">Strange Florida</a></div></li></ul></li><li class="Box-sc-12ejyki-0 cGFgHT primary"><ul class="Box-sc-12ejyki-0 efLRKi secondary"><li class="Box-sc-12ejyki-0 kaPImw parent"><div class="Box-sc-12ejyki-0 fdOGcB gaevent"><a href="/getting-results/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/getting-results">Getting Results.</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Weekly/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Weekly/" gavalue="0">The Weekly</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Driving_Change/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Driving_Change/" gavalue="1">Driving Change</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Getting_Results_Together/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Getting_Results_Together/" gavalue="2">Getting Results Together</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Getting_Results_In_Our_Schools/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Getting_Results_In_Our_Schools/" gavalue="3">Getting Results For Our Schools</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Getting_Results_For_Your_Health/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Getting_Results_For_Your_Health/" gavalue="4">Getting Results For Your Health</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Award_Winners/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Award_Winners/" gavalue="5">Award Winners</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/getting-results/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/getting-results/" gavalue="6">Need Results?</a></div></li></ul></li><li class="Box-sc-12ejyki-0 cGFgHT primary"><ul class="Box-sc-12ejyki-0 efLRKi secondary"><li class="Box-sc-12ejyki-0 kaPImw parent"><div class="Box-sc-12ejyki-0 fdOGcB gaevent"><a href="/weather/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/weather">Weather</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Weather_News/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Weather_News/" gavalue="0">Weather News</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/pins/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/pins" gavalue="1">PinIt!</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/hurricane/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/hurricane/" gavalue="2">Hurricane</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Forecasting_Change/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Forecasting_Change/" gavalue="3">Forecasting Change</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/weather/alerts/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/weather/alerts/" gavalue="4">Alerts</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/news/2019/11/11/live-camera-orlando-health/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/news/2019/11/11/live-camera-orlando-health/" gavalue="5">Live Orlando Cam</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/news/2019/11/12/live-camera-daytona-beach/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/news/2019/11/12/live-camera-daytona-beach/" gavalue="6">Live Beach Cam</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/news/local/2020/01/30/live-camera-port-canaveral/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/news/local/2020/01/30/live-camera-port-canaveral/" gavalue="7">Live Port Cam</a></div></li></ul></li><li class="Box-sc-12ejyki-0 cGFgHT primary"><ul class="Box-sc-12ejyki-0 efLRKi secondary"><li class="Box-sc-12ejyki-0 kaPImw parent"><div class="Box-sc-12ejyki-0 fdOGcB gaevent"><a href="/traffic/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/traffic">Traffic</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/news/ask-trooper-steve/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/news/ask-trooper-steve" gavalue="0">Ask Trooper Steve</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/What_The_Honk/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/What_The_Honk/" gavalue="1">What The Honk?</a></div></li></ul></li><li class="Box-sc-12ejyki-0 cGFgHT primary"><ul class="Box-sc-12ejyki-0 efLRKi secondary"><li class="Box-sc-12ejyki-0 kaPImw parent"><div class="Box-sc-12ejyki-0 fdOGcB gaevent"><a href="/features/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/features">Features</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/deals/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/deals" gavalue="0">Shop ClickOrando Deals</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/theme-parks/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/theme-parks" gavalue="1">Theme Parks</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Fathers_Day/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Fathers_Day/" gavalue="2">Father's Day</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Juneteenth/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Juneteenth/" gavalue="3">Juneteenth</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/pets/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/pets/" gavalue="4">Pets</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/food/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/food" gavalue="5">Food</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/health/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/health" gavalue="6">Health</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Travel/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Travel/" gavalue="7">Travel</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Make_Ends_Meet/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Make_Ends_Meet/" gavalue="8">Make Ends Meet</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/money/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/money" gavalue="9">Money</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/tech/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/tech" gavalue="10">Tech</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Something_Good/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Something_Good/" gavalue="11">Something Good</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Pros_Who_Know/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Pros_Who_Know/" gavalue="12">Pros Who Know</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/rememberingpulse49/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/rememberingpulse49/" gavalue="13">Remembering Pulse</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/realtalk/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/realtalk/" gavalue="14">Real Talk</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/solutionaries/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/solutionaries/" gavalue="15">Solutionaries</a></div></li></ul></li><li class="Box-sc-12ejyki-0 cGFgHT primary"><ul class="Box-sc-12ejyki-0 efLRKi secondary"><li class="Box-sc-12ejyki-0 kaPImw parent"><div class="Box-sc-12ejyki-0 fdOGcB gaevent"><a href="/topic/podcasts/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/topic/podcasts">Podcasts</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Florida_Foodie/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Florida_Foodie/" gavalue="0">Florida Foodie</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Fourth_Estate/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Fourth_Estate/" gavalue="1">Fourth Estate</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Space_Curious/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Space_Curious/" gavalue="2">Space Curious</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Hecht_Effect/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Hecht_Effect/" gavalue="3">The Hecht Effect</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Ask_Holly/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Ask_Holly/" gavalue="4">Ask Holly</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/You_Have_Real_Estate/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/You_Have_Real_Estate/" gavalue="5">Real Estate</a></div></li></ul></li><li class="Box-sc-12ejyki-0 cGFgHT primary"><ul class="Box-sc-12ejyki-0 efLRKi secondary"><li class="Box-sc-12ejyki-0 kaPImw parent"><div class="Box-sc-12ejyki-0 fdOGcB gaevent"><a href="/sports/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/sports">Sports</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/sports/2021/03/10/madness-take-on-news-6-and-make-your-picks-in-the-bracket-challenge/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/sports/2021/03/10/madness-take-on-news-6-and-make-your-picks-in-the-bracket-challenge/" gavalue="0">Bracket Challenge</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Magic/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Magic/" gavalue="1">Orlando Magic</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Knights/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Knights/" gavalue="2">UCF Knights</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Gators/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Gators/" gavalue="3">Florida Gators</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Orlando_City/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Orlando_City/" gavalue="4">Orlando City SC</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Orlando_Pride/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Orlando_Pride/" gavalue="5">Orlando Pride</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Dolphins/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Dolphins/" gavalue="6">Miami Dolphins</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Buccaneers/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Buccaneers/" gavalue="7">Tampa Bay Buccaneers</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Jaguars/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Jaguars/" gavalue="8">Jacksonville Jaguars</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/topic/Solar_Bears/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/topic/Solar_Bears/" gavalue="9">Orlando Solar Bears</a></div></li></ul></li><li class="Box-sc-12ejyki-0 cGFgHT primary"><ul class="Box-sc-12ejyki-0 efLRKi secondary"><li class="Box-sc-12ejyki-0 kaPImw parent"><div class="Box-sc-12ejyki-0 fdOGcB gaevent"><a href="/station/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/station">WKMG</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/team/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/team/" gavalue="0">Meet The Team</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/contact/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/contact/" gavalue="1">Contact Us</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/careers/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/careers" gavalue="2">Careers at WKMG</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/contests/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/contests/" gavalue="3">Contests & Rules</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/tv-listings/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/tv-listings/" gavalue="4">TV Listings</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/community-calendar/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/community-calendar/" gavalue="5">Community Calendar</a></div></li><li class="Box-sc-12ejyki-0 faMlgr sub"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/account/newsletters/" gacategory="Nav" gaaction="Hamburger Secondary" galabel="/account/newsletters/" gavalue="6">Newsletters</a></div></li></ul></li><li class="Box-sc-12ejyki-0 cGFgHT primary"><ul class="Box-sc-12ejyki-0 efLRKi secondary"><li class="Box-sc-12ejyki-0 kaPImw parent"><div class="Box-sc-12ejyki-0 fdOGcB gaevent"><a href="/account/newsletters/" gacategory="Nav" gaaction="Hamburger Primary" galabel="/account/newsletters/">Newsletters</a></div></li></ul></li></ul></nav></div></div><nav class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 cTWEtd spotlight"><ul class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 gueTsy"><li><div class="Box-sc-12ejyki-0 bgpVcv gaevent uppercase"><a href="/news/" gacategory="Nav" gaaction="Spotlight" galabel="/news/">News</a></div></li><li><div class="Box-sc-12ejyki-0 bgpVcv gaevent uppercase"><a href="/getting-results/" gacategory="Nav" gaaction="Spotlight" galabel="/getting-results/">Getting Results.</a></div></li><li><div class="Box-sc-12ejyki-0 bgpVcv gaevent uppercase"><a href="/weather/" gacategory="Nav" gaaction="Spotlight" galabel="/weather/">Weather</a></div></li><li><div class="Box-sc-12ejyki-0 bgpVcv gaevent uppercase"><a href="/traffic/" gacategory="Nav" gaaction="Spotlight" galabel="/traffic/">Traffic</a></div></li><li><div class="Box-sc-12ejyki-0 bgpVcv gaevent uppercase"><a href="/features/" gacategory="Nav" gaaction="Spotlight" galabel="/features/">Features</a></div></li><li><div class="Box-sc-12ejyki-0 bgpVcv gaevent uppercase"><a href="/topic/podcasts/" gacategory="Nav" gaaction="Spotlight" galabel="/topic/podcasts/">Podcasts</a></div></li><li><div class="Box-sc-12ejyki-0 bgpVcv gaevent uppercase"><a href="/sports/" gacategory="Nav" gaaction="Spotlight" galabel="/sports/">Sports</a></div></li><li><div class="Box-sc-12ejyki-0 bgpVcv gaevent uppercase"><a href="/station/" gacategory="Nav" gaaction="Spotlight" galabel="/station/">WKMG</a></div></li><li><div class="Box-sc-12ejyki-0 bgpVcv gaevent uppercase"><a href="/account/newsletters/" gacategory="Nav" gaaction="Spotlight" galabel="/account/newsletters/">Newsletters</a></div></li></ul></nav><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 fDULNQ transition-300"><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 hiRkNr container"><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 cLGXPz"><div class="Box-sc-12ejyki-0 fLgRBc pointer"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="bars" class="svg-inline--fa fa-bars fa-w-14 fa-fw " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M16 132h416c8.837 0 16-7.163 16-16V76c0-8.837-7.163-16-16-16H16C7.163 60 0 67.163 0 76v40c0 8.837 7.163 16 16 16zm0 160h416c8.837 0 16-7.163 16-16v-40c0-8.837-7.163-16-16-16H16c-8.837 0-16 7.163-16 16v40c0 8.837 7.163 16 16 16zm0 160h416c8.837 0 16-7.163 16-16v-40c0-8.837-7.163-16-16-16H16c-8.837 0-16 7.163-16 16v40c0 8.837 7.163 16 16 16z"></path></svg></div><a class="logo" href="/"><figure class="Box-sc-12ejyki-0 ecwFvf"><div class="Box-sc-12ejyki-0 cOJUZB imageWrapper"><div class="Box-sc-12ejyki-0 jKvIth"></div><div style="height:16px" class="lazyload-placeholder"></div></div></figure></a></div><nav class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 fECuNw spotlight"><ul class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 edjlNO"><li class="Box-sc-12ejyki-0 eayAjN"><div class="Box-sc-12ejyki-0 dUdVZO"><div class="Box-sc-12ejyki-0 iCCVDB gaevent uppercase"><a href="/news/" gacategory="Nav" gaaction="MiniBar" galabel="/news/" gavalue="0">News</a></div></div></li><li class="Box-sc-12ejyki-0 eayAjN"><div class="Box-sc-12ejyki-0 dUdVZO"><div class="Box-sc-12ejyki-0 iCCVDB gaevent uppercase"><a href="/getting-results/" gacategory="Nav" gaaction="MiniBar" galabel="/getting-results/" gavalue="1">Getting Results.</a></div></div></li><li class="Box-sc-12ejyki-0 eayAjN"><div class="Box-sc-12ejyki-0 dUdVZO"><div class="Box-sc-12ejyki-0 iCCVDB gaevent uppercase"><a href="/weather/" gacategory="Nav" gaaction="MiniBar" galabel="/weather/" gavalue="2">Weather</a></div></div></li><li class="Box-sc-12ejyki-0 eayAjN"><div class="Box-sc-12ejyki-0 dUdVZO"><div class="Box-sc-12ejyki-0 iCCVDB gaevent uppercase"><a href="/traffic/" gacategory="Nav" gaaction="MiniBar" galabel="/traffic/" gavalue="3">Traffic</a></div></div></li><li class="Box-sc-12ejyki-0 eayAjN"><div class="Box-sc-12ejyki-0 dUdVZO"><div class="Box-sc-12ejyki-0 iCCVDB gaevent uppercase"><a href="/features/" gacategory="Nav" gaaction="MiniBar" galabel="/features/" gavalue="4">Features</a></div></div></li><li class="Box-sc-12ejyki-0 eayAjN"><div class="Box-sc-12ejyki-0 dUdVZO"><div class="Box-sc-12ejyki-0 iCCVDB gaevent uppercase"><a href="/topic/podcasts/" gacategory="Nav" gaaction="MiniBar" galabel="/topic/podcasts/" gavalue="5">Podcasts</a></div></div></li><li class="Box-sc-12ejyki-0 eayAjN"><div class="Box-sc-12ejyki-0 dUdVZO"><div class="Box-sc-12ejyki-0 iCCVDB gaevent uppercase"><a href="/sports/" gacategory="Nav" gaaction="MiniBar" galabel="/sports/" gavalue="6">Sports</a></div></div></li><li class="Box-sc-12ejyki-0 eayAjN"><div class="Box-sc-12ejyki-0 dUdVZO"><div class="Box-sc-12ejyki-0 iCCVDB gaevent uppercase"><a href="/station/" gacategory="Nav" gaaction="MiniBar" galabel="/station/" gavalue="7">WKMG</a></div></div></li><li class="Box-sc-12ejyki-0 eayAjN"><div class="Box-sc-12ejyki-0 dUdVZO"><div class="Box-sc-12ejyki-0 iCCVDB gaevent uppercase"><a href="/account/newsletters/" gacategory="Nav" gaaction="MiniBar" galabel="/account/newsletters/" gavalue="8">Newsletters</a></div></div></li></ul></nav></div></div></header><section class="Box-sc-12ejyki-0 kaPImw wrapper"><main class="Box-sc-12ejyki-0 geIAAj article" role="main"><section class="Box-sc-12ejyki-0 jdBinm top-wide"><div class="scGrid full-width twoCol" id="0f4QEZVpGrA"><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 gKfpUK ssrAdSkeleton" aria-hidden="true"><span class="Text__BaseText-mmkwcw-0 TXBN" role="presentation">Ad</span></div></div></section><aside id="article" class="Box-sc-12ejyki-0 tEfJj"><section class="chainGroup" id="0f1VvA1iDrr"><div class="Box-sc-12ejyki-0 kaPImw articleInfo"><div class="Box-sc-12ejyki-0 kjNniI"><h4 class="Header__StyledHeader-qoaq48-0 MWZoW"><div class="Box-sc-12ejyki-0 jXmjsZ gaevent"><a href="/news/local" gacategory="Article Rail" gaaction="Section Link" galabel="Local News">Local News</a></div></h4><hr class="Box-sc-12ejyki-0 Divider__BaseDivider-sc-1ie9vi7-0 hkOvmC"/></div><div class="Box-sc-12ejyki-0 irEEaG metadata"><div class="Box-sc-12ejyki-0 kjNniI byline"><p class="Text__BaseText-mmkwcw-0 jFgmSC author"><div class="Box-sc-12ejyki-0 jeDXwL gaevent"><a href="/team/XZOBO4D3XFHHVKRORQRC5OKNUM/" gacategory="Article Rail" gaaction="Author Link" galabel="Emilee Speck" gavalue="0">Emilee Speck</a></div>, Digital journalist</p></div><div class="Box-sc-12ejyki-0 bCgwSc time"><time class="Text__BaseText-mmkwcw-0 kvtnlw" dateTime="2021-06-22T14:18:53.365Z">Published: <span class="Text__BaseText-mmkwcw-0 fFWmJ"><time dateTime="1624371533365" class="">June 22, 2021 10:18 am</time></span></time></div><div class="Box-sc-12ejyki-0 dQNexQ tags">Tags: <span class="Text__BaseText-mmkwcw-0 jCEkSM"><div class="Box-sc-12ejyki-0 jXmjsZ"><a href="/topic/Orlando/" gacategory="Article Rail" gaaction="Tag Link">Orlando</a></div>, <div class="Box-sc-12ejyki-0 jXmjsZ"><a href="/topic/Orange_County/" gacategory="Article Rail" gaaction="Tag Link">Orange County</a></div>, <div class="Box-sc-12ejyki-0 jXmjsZ"><a href="/topic/Roberto_Clemente/" gacategory="Article Rail" gaaction="Tag Link">Roberto Clemente</a></div></span></div></div><hr class="Box-sc-12ejyki-0 Divider__BaseDivider-sc-1ie9vi7-0 bdblZq"/></div><div><h5>Sign up for our Newsletters</h5><form action="" class="formField transition-300 mb-med" encType="application/x-www-form-urlencoded" method="GET" name="" role=""><div class="textFieldWrap relative font_openSans font_regular"><input type="email" aria-invalid="false" autoComplete="" class="transition-500 sm" name="email" placeholder="Enter your email here!" value=""/><label class="transition-100 text_left absolute font_gibson font_medium"></label></div></form></div><div id="fusion-static-enter:0faiKp1iDrJ" style="display:none" data-fusion-component="0faiKp1iDrJ"></div><div class="social-share | display_flex | mb-norm | justify_center | align_items_center"><div class="viafoura"><div class="vf-widget vf-share-bar-circle vf-share-bar-bw" data-widget="sharebar" data-button-view="false" data-show-labels="false" data-show-counters="false" data-show-total="false" data-share-current-page-url="true"></div></div><div class="viafoura"><a class="com-anchor | display_block | color_black" href="#comments"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="comments" class="svg-inline--fa fa-comments fa-w-18 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 576 512" style="max-height:1.5rem"><path fill="currentColor" d="M416 192c0-88.4-93.1-160-208-160S0 103.6 0 192c0 34.3 14.1 65.9 38 92-13.4 30.2-35.5 54.2-35.8 54.5-2.2 2.3-2.8 5.7-1.5 8.7S4.8 352 8 352c36.6 0 66.9-12.3 88.7-25 32.2 15.7 70.3 25 111.3 25 114.9 0 208-71.6 208-160zm122 220c23.9-26 38-57.7 38-92 0-66.9-53.5-124.2-129.3-148.1.9 6.6 1.3 13.3 1.3 20.1 0 105.9-107.7 192-240 192-10.8 0-21.3-.8-31.7-1.9C207.8 439.6 281.8 480 368 480c41 0 79.1-9.2 111.3-25 21.8 12.7 52.1 25 88.7 25 3.2 0 6.1-1.9 7.3-4.8 1.3-2.9.7-6.3-1.5-8.7-.3-.3-22.4-24.2-35.8-54.5z"></path></svg><span class="vf-counter vf-widget font_gibson font_semibold" data-widget="counter"></span></a></div></div><hr class="Box-sc-12ejyki-0 Divider__BaseDivider-sc-1ie9vi7-0 leOKfn"/><div id="fusion-static-exit:0faiKp1iDrJ" style="display:none" data-fusion-component="0faiKp1iDrJ"></div></section><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 jFLeST ssrAdSkeleton" aria-hidden="true"><span class="Text__BaseText-mmkwcw-0 gXpKOb" role="presentation">Ad</span></div><section class="storyList"><h4 class="mb-sm" style="text-transform:uppercase">Related Stories</h4><hr class="bold" style="margin-bottom:1rem"/><section class="topic textOverlay"><div class="grid story-list gap_x_norm gap_y_norm vertical"><article class="storyCard mb-norm" style="margin:0"><div class="sc-htpNat indexes__StackBase-klv0wy-4 hLkLrx relative min gridItem height_full horizontal "><div class="sc-htpNat indexes__StackBase-klv0wy-4 hTqPlS articleMeta width_full"><span class="sc-htpNat indexes__LinkBase-klv0wy-6 kVPDul"><a href="/news/local/2021/03/26/central-florida-artist-creates-mural-for-roberto-clemente-middle-school/" target="_self" gacategory="Story Card" gaaction="Related Content" galabel="/news/local/2021/03/26/central-florida-artist-creates-mural-for-roberto-clemente-middle-school/" gavalue="0"></a></span><a class="display_block gaevent" href="/news/local/2021/03/26/central-florida-artist-creates-mural-for-roberto-clemente-middle-school/" target="_self" gacategory="Story Card" gaaction="Related Content" galabel="/news/local/2021/03/26/central-florida-artist-creates-mural-for-roberto-clemente-middle-school/" gavalue="0"><h3 class="no-margin">Central Florida artist creates mural for Roberto Clemente Middle School</h3></a></div></div></article><hr class="regular"/><article class="storyCard mb-norm" style="margin:0"><div class="sc-htpNat indexes__StackBase-klv0wy-4 hLkLrx relative min gridItem height_full horizontal "><div class="sc-htpNat indexes__StackBase-klv0wy-4 hTqPlS articleMeta width_full"><span class="sc-htpNat indexes__LinkBase-klv0wy-6 kVPDul"><a href="/features/2020/09/29/roberto-clemente-more-than-latin-americas-baseball-star/" target="_self" gacategory="Story Card" gaaction="Related Content" galabel="/features/2020/09/29/roberto-clemente-more-than-latin-americas-baseball-star/" gavalue="1"></a></span><a class="display_block gaevent" href="/features/2020/09/29/roberto-clemente-more-than-latin-americas-baseball-star/" target="_self" gacategory="Story Card" gaaction="Related Content" galabel="/features/2020/09/29/roberto-clemente-more-than-latin-americas-baseball-star/" gavalue="1"><h3 class="no-margin">Roberto Clemente: More than Latin America’s baseball star</h3></a></div></div></article><hr class="regular"/><article class="storyCard mb-norm" style="margin:0"><div class="sc-htpNat indexes__StackBase-klv0wy-4 hLkLrx relative min gridItem height_full horizontal "><div class="sc-htpNat indexes__StackBase-klv0wy-4 hTqPlS articleMeta width_full"><span class="sc-htpNat indexes__LinkBase-klv0wy-6 kVPDul"><a href="/sports/2020/12/07/adam-wainwright-wins-mlbs-roberto-clemente-award/" target="_self" gacategory="Story Card" gaaction="Related Content" galabel="/sports/2020/12/07/adam-wainwright-wins-mlbs-roberto-clemente-award/" gavalue="2"></a></span><a class="display_block gaevent" href="/sports/2020/12/07/adam-wainwright-wins-mlbs-roberto-clemente-award/" target="_self" gacategory="Story Card" gaaction="Related Content" galabel="/sports/2020/12/07/adam-wainwright-wins-mlbs-roberto-clemente-award/" gavalue="2"><h3 class="no-margin">Adam Wainwright wins MLB's Roberto Clemente Award</h3></a></div></div></article><hr class="regular"/><article class="storyCard mb-norm" style="margin:0"><div class="sc-htpNat indexes__StackBase-klv0wy-4 hLkLrx relative min gridItem height_full horizontal "><div class="sc-htpNat indexes__StackBase-klv0wy-4 hTqPlS articleMeta width_full"><span class="sc-htpNat indexes__LinkBase-klv0wy-6 kVPDul"><a href="/sports/2020/09/09/for-the-great-one-pirates-mlb-honor-roberto-clemente/" target="_self" gacategory="Story Card" gaaction="Related Content" galabel="/sports/2020/09/09/for-the-great-one-pirates-mlb-honor-roberto-clemente/" gavalue="3"></a></span><a class="display_block gaevent" href="/sports/2020/09/09/for-the-great-one-pirates-mlb-honor-roberto-clemente/" target="_self" gacategory="Story Card" gaaction="Related Content" galabel="/sports/2020/09/09/for-the-great-one-pirates-mlb-honor-roberto-clemente/" gavalue="3"><h3 class="no-margin">For the 'Great One'; Pirates, MLB honor Roberto Clemente</h3></a></div></div></article></div></section></section><aside id="0fPgeUQdGrU" class="Box-sc-12ejyki-0 hJxlgt"><div class="Box-sc-12ejyki-0 hnikHe"><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 jFLeST ssrAdSkeleton" aria-hidden="true"><span class="Text__BaseText-mmkwcw-0 gXpKOb" role="presentation">Ad</span></div><div class="sc-htpNat indexes__StackBase-klv0wy-4 eBRlta"><div class="sc-htpNat indexes__StackBase-klv0wy-4 gIzSgu"><h2 class="sc-htpNat indexes__HeadingBase-klv0wy-3 dchGiv"><a class="sc-htpNat indexes__LinkBase-klv0wy-6 JGBpd" href="/news/local/">LATEST NEWS</a></h2><hr class="sc-htpNat indexes__BaseDivider-klv0wy-5 haoJbT"/></div><div class="sc-htpNat KtFsv storyListNext"><div class="sc-htpNat indexes__GridBase-klv0wy-9 dJuWiv"><article class="sc-htpNat indexes__StackBase-klv0wy-4 hTqPlS"><div class="sc-htpNat indexes__StackBase-klv0wy-4 eWLGCT"><span class="sc-htpNat indexes__LinkBase-klv0wy-6 fejUQY"><a href="/news/local/2021/06/22/fictional-space-tale-holdout-weaves-earths-real-woes-into-astronauts-personal-mission/" gaaction="Story List" gaalue="0"><figure class="Box-sc-12ejyki-0 feNIHh"><div class="Box-sc-12ejyki-0 ldtmQG imageWrapper"><div class="Box-sc-12ejyki-0 jKvIth"></div><div style="height:720px" class="lazyload-placeholder"></div></div></figure></a></span><div class="sc-htpNat icxcVO"><div class="sc-htpNat indexes__StackBase-klv0wy-4 kiEpJN"><span class="sc-htpNat indexes__LinkBase-klv0wy-6 JGBpd"><a href="/news/local/2021/06/22/fictional-space-tale-holdout-weaves-earths-real-woes-into-astronauts-personal-mission/" gaaction="Story List" gaalue="0"><span class="sc-htpNat indexes__TextBase-klv0wy-1 dlnJrb">9 minutes ago</span></a></span><span class="sc-htpNat indexes__LinkBase-klv0wy-6 JGBpd"><a href="/news/local/2021/06/22/fictional-space-tale-holdout-weaves-earths-real-woes-into-astronauts-personal-mission/" gaaction="Story List" gaalue="0"><h3 title="Fictional space tale ‘Holdout’ weaves Earth’s real woes into astronaut’s personal mission" class="sc-htpNat indexes__HeadingBase-klv0wy-3 fmbrWI">Fictional space tale ‘Holdout’ weaves Earth’s real woes into astronaut’s personal mission</h3></a></span></div></div></div></article><article class="sc-htpNat indexes__StackBase-klv0wy-4 hTqPlS"><div class="sc-htpNat indexes__StackBase-klv0wy-4 eWLGCT"><span class="sc-htpNat indexes__LinkBase-klv0wy-6 fejUQY"><a href="/news/local/2021/06/18/body-found-in-submerged-car-in-malabar-deputies-say/" gaaction="Story List" gaalue="1"><figure class="Box-sc-12ejyki-0 feNIHh"><div class="Box-sc-12ejyki-0 ldtmQG imageWrapper"><div class="Box-sc-12ejyki-0 jKvIth"></div><div style="height:720px" class="lazyload-placeholder"></div></div></figure></a></span><div class="sc-htpNat icxcVO"><div class="sc-htpNat indexes__StackBase-klv0wy-4 kiEpJN"><span class="sc-htpNat indexes__LinkBase-klv0wy-6 JGBpd"><a href="/news/local/2021/06/18/body-found-in-submerged-car-in-malabar-deputies-say/" gaaction="Story List" gaalue="1"><span class="sc-htpNat indexes__TextBase-klv0wy-1 dlnJrb">34 minutes ago</span></a></span><span class="sc-htpNat indexes__LinkBase-klv0wy-6 JGBpd"><a href="/news/local/2021/06/18/body-found-in-submerged-car-in-malabar-deputies-say/" gaaction="Story List" gaalue="1"><h3 title="Body of missing Palm Bay man found in submerged car in Malabar, deputies say" class="sc-htpNat indexes__HeadingBase-klv0wy-3 fmbrWI">Body of missing Palm Bay man found in submerged car in Malabar, deputies say</h3></a></span></div></div></div></article><article class="sc-htpNat indexes__StackBase-klv0wy-4 hTqPlS"><div class="sc-htpNat indexes__StackBase-klv0wy-4 eWLGCT"><span class="sc-htpNat indexes__LinkBase-klv0wy-6 fejUQY"><a href="/news/local/2021/06/22/street-next-to-roberto-clemente-middle-school-in-orlando-gets-new-name/" gaaction="Story List" gaalue="2"><figure class="Box-sc-12ejyki-0 feNIHh"><div class="Box-sc-12ejyki-0 ldtmQG imageWrapper"><div class="Box-sc-12ejyki-0 jKvIth"></div><div style="height:720px" class="lazyload-placeholder"></div></div></figure></a></span><div class="sc-htpNat icxcVO"><div class="sc-htpNat indexes__StackBase-klv0wy-4 kiEpJN"><span class="sc-htpNat indexes__LinkBase-klv0wy-6 JGBpd"><a href="/news/local/2021/06/22/street-next-to-roberto-clemente-middle-school-in-orlando-gets-new-name/" gaaction="Story List" gaalue="2"><span class="sc-htpNat indexes__TextBase-klv0wy-1 dlnJrb">1 hour ago</span></a></span><span class="sc-htpNat indexes__LinkBase-klv0wy-6 JGBpd"><a href="/news/local/2021/06/22/street-next-to-roberto-clemente-middle-school-in-orlando-gets-new-name/" gaaction="Story List" gaalue="2"><h3 title="Street next to Roberto Clemente Middle School in Orlando gets new name" class="sc-htpNat indexes__HeadingBase-klv0wy-3 fmbrWI">Street next to Roberto Clemente Middle School in Orlando gets new name</h3></a></span></div></div></div></article><article class="sc-htpNat indexes__StackBase-klv0wy-4 hTqPlS"><div class="sc-htpNat indexes__StackBase-klv0wy-4 eWLGCT"><span class="sc-htpNat indexes__LinkBase-klv0wy-6 fejUQY"><a href="/news/local/2021/06/22/150-amazon-packages-sent-to-womans-home-by-mistake/" gaaction="Story List" gaalue="3"><figure class="Box-sc-12ejyki-0 feNIHh"><div class="Box-sc-12ejyki-0 ldtmQG imageWrapper"><div class="Box-sc-12ejyki-0 jKvIth"></div><div style="height:720px" class="lazyload-placeholder"></div></div></figure></a></span><div class="sc-htpNat icxcVO"><div class="sc-htpNat indexes__StackBase-klv0wy-4 kiEpJN"><span class="sc-htpNat indexes__LinkBase-klv0wy-6 JGBpd"><a href="/news/local/2021/06/22/150-amazon-packages-sent-to-womans-home-by-mistake/" gaaction="Story List" gaalue="3"><span class="sc-htpNat indexes__TextBase-klv0wy-1 dlnJrb">1 hour ago</span></a></span><span class="sc-htpNat indexes__LinkBase-klv0wy-6 JGBpd"><a href="/news/local/2021/06/22/150-amazon-packages-sent-to-womans-home-by-mistake/" gaaction="Story List" gaalue="3"><h3 title="150 Amazon packages sent to woman’s home by mistake" class="sc-htpNat indexes__HeadingBase-klv0wy-3 fmbrWI">150 Amazon packages sent to woman’s home by mistake</h3></a></span></div></div></div></article></div></div></div></div></aside></aside><section class="Box-sc-12ejyki-0 jfrLJo mainContent"><div class="sc-htpNat iRIfME articleInfo"><h4 class="sc-htpNat indexes__HeadingBase-klv0wy-3 guuoai"><span class="sc-htpNat indexes__LinkBase-klv0wy-6 JGBpd"><a href="/news/local" gacategory="Article Rail" gaaction="Section Link" galabel="Local News">Local News</a></span></h4></div><article class="sc-htpNat indexes__StackBase-klv0wy-4 khlKXP story"><div class="sc-htpNat indexes__StackBase-klv0wy-4 frNGhP"><h1 class="sc-htpNat indexes__HeadingBase-klv0wy-3 dxLtzo headline">Street next to Roberto Clemente Middle School in Orlando gets new name</h1><h2 class="sc-htpNat indexes__HeadingBase-klv0wy-3 ldlkLX subheadline">Roberto Clemente broke barriers before his untimely death</h2></div><div class="sc-htpNat indexes__StackBase-klv0wy-4 eJRilf metadata"><div class="Box-sc-12ejyki-0 kjNniI byline"><p class="Text__BaseText-mmkwcw-0 jFgmSC author"><div class="Box-sc-12ejyki-0 jeDXwL gaevent"><a href="/team/XZOBO4D3XFHHVKRORQRC5OKNUM/" gacategory="Article Rail" gaaction="Author Link" galabel="Emilee Speck" gavalue="0">Emilee Speck</a></div>, Digital journalist</p></div><div class="sc-htpNat kcEFxM time"><time dateTime="2021-06-22T14:18:53.365Z" class="sc-htpNat indexes__TextBase-klv0wy-1 eDCJmp">Published: <span class="sc-htpNat indexes__TextBase-klv0wy-1 fhKfXJ"><time dateTime="1624371533365" class="">June 22, 2021 10:18 am</time></span></time></div><div class="Box-sc-12ejyki-0 dQNexQ tags">Tags: <span class="Text__BaseText-mmkwcw-0 jCEkSM"><div class="Box-sc-12ejyki-0 jXmjsZ"><a href="/topic/Orlando/" gacategory="Article Rail" gaaction="Tag Link">Orlando</a></div>, <div class="Box-sc-12ejyki-0 jXmjsZ"><a href="/topic/Orange_County/" gacategory="Article Rail" gaaction="Tag Link">Orange County</a></div>, <div class="Box-sc-12ejyki-0 jXmjsZ"><a href="/topic/Roberto_Clemente/" gacategory="Article Rail" gaaction="Tag Link">Roberto Clemente</a></div></span></div></div><div class="sc-htpNat indexes__StackBase-klv0wy-4 frWjXu basicStory"><figure class="Box-sc-12ejyki-0 iVNNhU promo full-width"><div class="Box-sc-12ejyki-0 ldtmQG imageWrapper"><img class="Box-sc-12ejyki-0 kaPImw promo full-width" decoding="async" sizes="(min-width: 1200px) 850px, (min-width: 768px) and (max-width: 1199) 100vw, 50vw" src="https://www.clickorlando.com/resizer/2O6dggXfGmt5fGYwD193j4js2Xs=/800x450/smart/filters:format(jpeg):strip_exif(true):strip_icc(true):no_upscale(true):quality(65):fill(FFF)/cloudfront-us-east-1.images.arcpublishing.com/gmg/SBLQ6DJ2Z5BB7MXPRU3EUUL7EY.jpg" alt="Central Florida artist creates mural for Roberto Clemente Middle School"/></div><figcaption class="Box-sc-12ejyki-0 eGIiXs"><span class="Text__BaseText-mmkwcw-0 kxdhCj">Central Florida artist creates mural for Roberto Clemente Middle School</span></figcaption></figure><section class="Box-sc-12ejyki-0 cWpTbe articleBody" itemProp="articleBody"><div class="mobileOnly"><div class="social-share | display_flex | mb-norm | justify_center | align_items_center"><div class="viafoura"><div class="vf-widget vf-share-bar-circle vf-share-bar-bw" data-widget="sharebar" data-button-view="false" data-show-labels="false" data-show-counters="false" data-show-total="false" data-share-current-page-url="true"></div></div><div class="viafoura"><a class="com-anchor | display_block | color_black" href="#comments"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="comments" class="svg-inline--fa fa-comments fa-w-18 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 576 512" style="max-height:1.5rem"><path fill="currentColor" d="M416 192c0-88.4-93.1-160-208-160S0 103.6 0 192c0 34.3 14.1 65.9 38 92-13.4 30.2-35.5 54.2-35.8 54.5-2.2 2.3-2.8 5.7-1.5 8.7S4.8 352 8 352c36.6 0 66.9-12.3 88.7-25 32.2 15.7 70.3 25 111.3 25 114.9 0 208-71.6 208-160zm122 220c23.9-26 38-57.7 38-92 0-66.9-53.5-124.2-129.3-148.1.9 6.6 1.3 13.3 1.3 20.1 0 105.9-107.7 192-240 192-10.8 0-21.3-.8-31.7-1.9C207.8 439.6 281.8 480 368 480c41 0 79.1-9.2 111.3-25 21.8 12.7 52.1 25 88.7 25 3.2 0 6.1-1.9 7.3-4.8 1.3-2.9.7-6.3-1.5-8.7-.3-.3-22.4-24.2-35.8-54.5z"></path></svg><span class="vf-counter vf-widget font_gibson font_semibold" data-widget="counter"></span></a></div></div></div><p class="Text__BaseText-mmkwcw-0 dRMzTN"><strong>ORLANDO, Fla.</strong> – The street where Roberto Clemente Middle School sits will officially be renamed after the famous Latino community baseball star this Wednesday, the city of Orlando announced.</p><p class="Text__BaseText-mmkwcw-0 dRMzTN">The middle school was renamed last year after the late ballplayer after the community worked with the school board to rename the campus from Stonewall Jackson Middle to Roberto Clemente Middle School in September 2020.</p><p class="Text__BaseText-mmkwcw-0 dRMzTN"><b>[TRENDING: </b><a href="https://www.clickorlando.com/news/local/2021/06/21/deadly-shooting-erupted-at-annual-fathers-day-event-sunday-evening-in-wildwood/"><b>1 killed, 9 shot at Father’s Day event</b></a><b> | </b><a href="https://www.clickorlando.com/news/florida/2021/06/20/driver-crashes-into-florida-pride-parade-mayor-says-1-dead/"><b>Deadly Pride parade crash not intentional</b></a><b> | </b><a href="https://www.clickorlando.com/news/national/2021/06/21/claudette-regaining-strength-after-13-killed-in-alabama/"><b>TS Claudette cited in 13 deaths</b></a><b>]</b></p><div class="Box-sc-12ejyki-0 Flex__FlexBase-sc-15e388o-0 NUNlW ssrAdSkeleton" aria-hidden="true"><span class="Text__BaseText-mmkwcw-0 TXBN" role="presentation">Ad</span></div><p class="Text__BaseText-mmkwcw-0 dRMzTN">The city announced this week the street where the school sits will get a new sign for Roberto Clemente Road during a ceremony on Wednesday at 10:30 a.m.</p><p class="Text__BaseText-mmkwcw-0 dRMzTN">After the school’s name change, a mural by Neysa Millán was painted in his honor on a wall at the school. Images of Clemente’s children and his days as a Pittsburgh Pirate are part of the work of art.</p><p class="Text__BaseText-mmkwcw-0 dRMzTN">During his career, Clemente broke barriers, becoming the first Latin American player to collect 3,000 career hits in September 1972. The Puerto Rican athlete accomplished this feat before his untimely death on Dec. 31, 1972, when his plane crashed as he was delivering earthquake relief supplies to Nicaragua. The cargo plane crashed off the coast of Puerto Rico and his body was never found.</p></section><p class="sc-htpNat indexes__TextBase-klv0wy-1 lohLPY copyright">Copyright 2021 by WKMG ClickOrlando - All rights reserved.</p><hr class="sc-htpNat indexes__BaseDivider-klv0wy-5 jZyACL"/></div></article><div class="scGrid full-width oneCol" id="0fI31iIuLro"><section class="storyList mobileOnly mb-med"><h4 class="mb-sm" style="text-transform:uppercase">Related Stories</h4><hr class="bold" style="margin-bottom:1rem"/><section class="topic textBelow"><article class="storyCard mb-norm"><div class="sc-htpNat indexes__StackBase-klv0wy-4 jJnjDF relative min  "><span class="sc-htpNat indexes__LinkBase-klv0wy-6 kilsRi"><a href="/news/local/2021/03/26/central-florida-artist-creates-mural-for-roberto-clemente-middle-school/" target="_self" gacategory="Story Card" gaaction="Related Content" galabel="/news/local/2021/03/26/central-florida-artist-creates-mural-for-roberto-clemente-middle-school/" gavalue="0"><div class="image relative height_full"><figure class="Box-sc-12ejyki-0 feNIHh width_full height_full"><div class="Box-sc-12ejyki-0 ldtmQG imageWrapper"><div class="Box-sc-12ejyki-0 jKvIth"></div><div style="height:720px" class="lazyload-placeholder"></div></div></figure></div></a></span><div class="sc-htpNat indexes__StackBase-klv0wy-4 hTqPlS articleMeta width_full"><span class="sc-htpNat indexes__LinkBase-klv0wy-6 kVPDul"><a href="/news/local/2021/03/26/central-florida-artist-creates-mural-for-roberto-clemente-middle-school/" target="_self" gacategory="Story Card" gaaction="Related Content" galabel="/news/local/2021/03/26/central-florida-artist-creates-mural-for-roberto-clemente-middle-school/" gavalue="0"></a></span><a class="display_block gaevent" href="/news/local/2021/03/26/central-florida-artist-creates-mural-for-roberto-clemente-middle-school/" target="_self" gacategory="Story Card" gaaction="Related Content" galabel="/news/local/2021/03/26/central-florida-artist-creates-mural-for-roberto-clemente-middle-school/" gavalue="0"><h3 class="no-margin">Central Florida artist creates mural for Roberto Clemente Middle School</h3></a></div></div></article><article class="storyCard mb-norm"><div class="sc-htpNat indexes__StackBase-klv0wy-4 jJnjDF relative min  "><span class="sc-htpNat indexes__LinkBase-klv0wy-6 kilsRi"><a href="/features/2020/09/29/roberto-clemente-more-than-latin-americas-baseball-star/" target="_self" gacategory="Story Card" gaaction="Related Content" galabel="/features/2020/09/29/roberto-clemente-more-than-latin-americas-baseball-star/" gavalue="1"><div class="image relative height_full"><figure class="Box-sc-12ejyki-0 feNIHh width_full height_full"><div class="Box-sc-12ejyki-0 ldtmQG imageWrapper"><div class="Box-sc-12ejyki-0 jKvIth"></div><div style="height:720px" class="lazyload-placeholder"></div></div></figure></div></a></span><div class="sc-htpNat indexes__StackBase-klv0wy-4 hTqPlS articleMeta width_full"><span class="sc-htpNat indexes__LinkBase-klv0wy-6 kVPDul"><a href="/features/2020/09/29/roberto-clemente-more-than-latin-americas-baseball-star/" target="_self" gacategory="Story Card" gaaction="Related Content" galabel="/features/2020/09/29/roberto-clemente-more-than-latin-americas-baseball-star/" gavalue="1"></a></span><a class="display_block gaevent" href="/features/2020/09/29/roberto-clemente-more-than-latin-americas-baseball-star/" target="_self" gacategory="Story Card" gaaction="Related Content" galabel="/features/2020/09/29/roberto-clemente-more-than-latin-americas-baseball-star/" gavalue="1"><h3 class="no-margin">Roberto Clemente: More than Latin America’s baseball star</h3></a></div></div></article><article class="storyCard mb-norm"><div class="sc-htpNat indexes__StackBase-klv0wy-4 jJnjDF relative min  "><span class="sc-htpNat indexes__LinkBase-klv0wy-6 kilsRi"><a href="/sports/2020/12/07/adam-wainwright-wins-mlbs-roberto-clemente-award/" target="_self" gacategory="Story Card" gaaction="Related Content" galabel="/sports/2020/12/07/adam-wainwright-wins-mlbs-roberto-clemente-award/" gavalue="2"><div class="image relative height_full"><figure class="Box-sc-12ejyki-0 feNIHh width_full height_full"><div class="Box-sc-12ejyki-0 ldtmQG imageWrapper"><div class="Box-sc-12ejyki-0 jKvIth"></div><div style="height:720px" class="lazyload-placeholder"></div></div></figure></div></a></span><div class="sc-htpNat indexes__StackBase-klv0wy-4 hTqPlS articleMeta width_full"><span class="sc-htpNat indexes__LinkBase-klv0wy-6 kVPDul"><a href="/sports/2020/12/07/adam-wainwright-wins-mlbs-roberto-clemente-award/" target="_self" gacategory="Story Card" gaaction="Related Content" galabel="/sports/2020/12/07/adam-wainwright-wins-mlbs-roberto-clemente-award/" gavalue="2"></a></span><a class="display_block gaevent" href="/sports/2020/12/07/adam-wainwright-wins-mlbs-roberto-clemente-award/" target="_self" gacategory="Story Card" gaaction="Related Content" galabel="/sports/2020/12/07/adam-wainwright-wins-mlbs-roberto-clemente-award/" gavalue="2"><h3 class="no-margin">Adam Wainwright wins MLB's Roberto Clemente Award</h3></a></div></div></article><article class="storyCard mb-norm"><div class="sc-htpNat indexes__StackBase-klv0wy-4 jJnjDF relative min  "><span class="sc-htpNat indexes__LinkBase-klv0wy-6 kilsRi"><a href="/sports/2020/09/09/for-the-great-one-pirates-mlb-honor-roberto-clemente/" target="_self" gacategory="Story Card" gaaction="Related Content" galabel="/sports/2020/09/09/for-the-great-one-pirates-mlb-honor-roberto-clemente/" gavalue="3"><div class="image relative height_full"><figure class="Box-sc-12ejyki-0 feNIHh width_full height_full"><div class="Box-sc-12ejyki-0 ldtmQG imageWrapper"><div class="Box-sc-12ejyki-0 jKvIth"></div><div style="height:720px" class="lazyload-placeholder"></div></div></figure></div></a></span><div class="sc-htpNat indexes__StackBase-klv0wy-4 hTqPlS articleMeta width_full"><span class="sc-htpNat indexes__LinkBase-klv0wy-6 kVPDul"><a href="/sports/2020/09/09/for-the-great-one-pirates-mlb-honor-roberto-clemente/" target="_self" gacategory="Story Card" gaaction="Related Content" galabel="/sports/2020/09/09/for-the-great-one-pirates-mlb-honor-roberto-clemente/" gavalue="3"></a></span><a class="display_block gaevent" href="/sports/2020/09/09/for-the-great-one-pirates-mlb-honor-roberto-clemente/" target="_self" gacategory="Story Card" gaaction="Related Content" galabel="/sports/2020/09/09/for-the-great-one-pirates-mlb-honor-roberto-clemente/" gavalue="3"><h3 class="no-margin">For the 'Great One'; Pirates, MLB honor Roberto Clemente</h3></a></div></div></article></section></section></div><div id="bio" class="display_flex column mb-lg"><h4 class="uppercase">About the Author:</h4><div class="author-container display_flex column"><div class="Box-sc-12ejyki-0 ewQCSW author" itemscope="" itemType="http://schema.org/Person" itemProp="author"><figure class="Box-sc-12ejyki-0 feNIHh rounded-full"><div class="Box-sc-12ejyki-0 cOJUZB imageWrapper"><div class="Box-sc-12ejyki-0 jKvIth"></div><div style="height:86px" class="lazyload-placeholder"></div></div></figure><div class="authorInfo display_flex column"><h5 class="font_semibold no-margin"><a class="font_gibson font_semibold link blue" itemProp="url" href="/team/XZOBO4D3XFHHVKRORQRC5OKNUM"><span itemProp="name">Emilee Speck</span></a></h5><p class="font_openSans mb-sm">Emilee is a digital journalist for News 6 and ClickOrlando.com, where she writes about space and Central Florida news. Emilee hosts the Edward R. Murrow Award-winning podcast Space Curious. Previously, she was a space writer and web editor for the Orlando Sentinel and a web producer at the Naples Daily News.</p><div class="author-social display_flex row color_blue"><a href="mailto:especk@wkmg.com?subject=Re:Street next to Roberto Clemente Middle School in Orlando gets new name" class="mr-norm link blue display_flex align_items_center"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="envelope" class="svg-inline--fa fa-envelope fa-w-16 mr-xsm" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512" style="font-size:0.875rem;max-height:0.875rem"><path fill="currentColor" d="M502.3 190.8c3.9-3.1 9.7-.2 9.7 4.7V400c0 26.5-21.5 48-48 48H48c-26.5 0-48-21.5-48-48V195.6c0-5 5.7-7.8 9.7-4.7 22.4 17.4 52.1 39.5 154.1 113.6 21.1 15.4 56.7 47.8 92.2 47.6 35.7.3 72-32.8 92.3-47.6 102-74.1 131.6-96.3 154-113.7zM256 320c23.2.4 56.6-29.2 73.4-41.4 132.7-96.3 142.8-104.7 173.4-128.7 5.8-4.5 9.2-11.5 9.2-18.9v-19c0-26.5-21.5-48-48-48H48C21.5 64 0 85.5 0 112v19c0 7.4 3.4 14.3 9.2 18.9 30.6 23.9 40.7 32.4 173.4 128.7 16.8 12.2 50.2 41.8 73.4 41.4z"></path></svg><span class="font_gibson font_medium color_blue">email</span></a></div></div></div></div></div><div class="lazyload-placeholder"></div><section class="sponsored-content mb-xlg"><div class="content-block double mb-xlg"><div class="sponsored-content"><section class="content-block"><div id="gmg-outbrain-container"><div class="OUTBRAIN" data-src="https://www.clickorlando.com/news/local/2021/06/22/street-next-to-roberto-clemente-middle-school-in-orlando-gets-new-name/" data-widget-id="AR_3" data-ob-template="clickorlando.com"></div></div></section></div></div><div class="content-block mb-xlg"><div class="sponsored-content"><section class="content-block"><div id="gmg-outbrain-container"><div class="OUTBRAIN" data-src="https://www.clickorlando.com/news/local/2021/06/22/street-next-to-roberto-clemente-middle-school-in-orlando-gets-new-name/" data-widget-id="AR_4" data-ob-template="clickorlando.com"></div></div></section></div></div><div class="content-block mb-xlg"></div></section></section></main></section><footer class="font_gibson color_black width_full"><div id="fusion-static-enter:0fH6IRQdGrW" style="display:none" data-fusion-component="0fH6IRQdGrW"></div><div class="linkWrap box_content display_flex mCenter width_max" style="margin-bottom:2.5rem"><ul class="display_grid gap_x_lg gap_y_med no-margin width_full"><li class="font_regular"><a href="https://www.clickorlando.com/tv-listings/">TV Listings</a></li><li class="font_regular"><a href="https://www.clickorlando.com/contests/">Contests and Rules</a></li><li class="font_regular"><a href="https://www.clickorlando.com/account/newsletters/">Email Newsletters</a></li><li class="font_regular"><a href="https://www.clickorlando.com/rss/">RSS Feeds</a></li><li class="font_regular"><a href="https://www.clickorlando.com/news/2019/11/11/closed-captioning-information/">Closed Captioning</a></li><li class="font_regular"><a href="https://www.clickorlando.com/contact/">Contact Us / Follow on Social Media</a></li><li class="font_regular"><a href="https://www.clickorlando.com/careers/">Careers at WKMG</a></li><li class="font_regular"><a href="https://www.clickorlando.com/station/2019/11/11/terms-of-use/">Terms of Use</a></li><li class="font_regular"><a href="https://www.clickorlando.com/station/2019/11/11/privacy-policy/">Privacy Policy</a></li><li class="font_regular"><a href="https://www.clickorlando.com/station/2019/11/11/online-public-inspection-file/">Public File</a></li><li class="font_regular"><a href="https://www.clickorlando.com/station/2020/12/22/fcc-applications/">FCC Applications</a></li><li class="font_regular"><a href="https://publicfiles.fcc.gov/tv-profile/wkmg-tv/equal-employment-opportunity-records/additional-documents/eeo-public-file-reports/723baae8-a5cf-e194-3c58-210aa23225d5/">EEO Report</a></li><li class="font_regular"><a href="https://www.clickorlando.com/station/2019/11/11/online-public-inspection-file/">Disability Assistance</a></li><li class="font_regular"><a href="/usprivacy/">Do Not Sell My Info</a></li></ul><div class="followUs display_flex justify_space_between mb-xlg "><div class="social"><h6 class="color_black uppercase" style="letter-spacing:0.05em">Follow Us</h6><div class="icons display_flex"><a class="color_black gaevent" href="https://www.facebook.com/news6/" gacategory="Nav" gaaction="Footer Social" galabel="https://www.facebook.com/news6/"><svg aria-labelledby="svg-inline--fa-title-ZuRkblmjiCvx" data-prefix="fab" data-icon="facebook-f" class="svg-inline--fa fa-facebook-f fa-w-10 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 320 512"><title id="svg-inline--fa-title-ZuRkblmjiCvx">facebook</title><path fill="currentColor" d="M279.14 288l14.22-92.66h-88.91v-60.13c0-25.35 12.42-50.06 52.24-50.06h40.42V6.26S260.43 0 225.36 0c-73.22 0-121.08 44.38-121.08 124.72v70.62H22.89V288h81.39v224h100.17V288z"></path></svg></a><a class="color_black gaevent" href="https://twitter.com/news6wkmg/" gacategory="Nav" gaaction="Footer Social" galabel="https://twitter.com/news6wkmg/"><svg aria-labelledby="svg-inline--fa-title-4xBGiZuqeNJR" data-prefix="fab" data-icon="twitter" class="svg-inline--fa fa-twitter fa-w-16 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><title id="svg-inline--fa-title-4xBGiZuqeNJR">twitter</title><path fill="currentColor" d="M459.37 151.716c.325 4.548.325 9.097.325 13.645 0 138.72-105.583 298.558-298.558 298.558-59.452 0-114.68-17.219-161.137-47.106 8.447.974 16.568 1.299 25.34 1.299 49.055 0 94.213-16.568 130.274-44.832-46.132-.975-84.792-31.188-98.112-72.772 6.498.974 12.995 1.624 19.818 1.624 9.421 0 18.843-1.3 27.614-3.573-48.081-9.747-84.143-51.98-84.143-102.985v-1.299c13.969 7.797 30.214 12.67 47.431 13.319-28.264-18.843-46.781-51.005-46.781-87.391 0-19.492 5.197-37.36 14.294-52.954 51.655 63.675 129.3 105.258 216.365 109.807-1.624-7.797-2.599-15.918-2.599-24.04 0-57.828 46.782-104.934 104.934-104.934 30.213 0 57.502 12.67 76.67 33.137 23.715-4.548 46.456-13.32 66.599-25.34-7.798 24.366-24.366 44.833-46.132 57.827 21.117-2.273 41.584-8.122 60.426-16.243-14.292 20.791-32.161 39.308-52.628 54.253z"></path></svg></a><a class="color_black gaevent" href="https://www.instagram.com/news6wkmg/" gacategory="Nav" gaaction="Footer Social" galabel="https://www.instagram.com/news6wkmg/"><svg aria-labelledby="svg-inline--fa-title-tCeDpQxxDY0t" data-prefix="fab" data-icon="instagram" class="svg-inline--fa fa-instagram fa-w-14 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><title id="svg-inline--fa-title-tCeDpQxxDY0t">instagram</title><path fill="currentColor" d="M224.1 141c-63.6 0-114.9 51.3-114.9 114.9s51.3 114.9 114.9 114.9S339 319.5 339 255.9 287.7 141 224.1 141zm0 189.6c-41.1 0-74.7-33.5-74.7-74.7s33.5-74.7 74.7-74.7 74.7 33.5 74.7 74.7-33.6 74.7-74.7 74.7zm146.4-194.3c0 14.9-12 26.8-26.8 26.8-14.9 0-26.8-12-26.8-26.8s12-26.8 26.8-26.8 26.8 12 26.8 26.8zm76.1 27.2c-1.7-35.9-9.9-67.7-36.2-93.9-26.2-26.2-58-34.4-93.9-36.2-37-2.1-147.9-2.1-184.9 0-35.8 1.7-67.6 9.9-93.9 36.1s-34.4 58-36.2 93.9c-2.1 37-2.1 147.9 0 184.9 1.7 35.9 9.9 67.7 36.2 93.9s58 34.4 93.9 36.2c37 2.1 147.9 2.1 184.9 0 35.9-1.7 67.7-9.9 93.9-36.2 26.2-26.2 34.4-58 36.2-93.9 2.1-37 2.1-147.8 0-184.8zM398.8 388c-7.8 19.6-22.9 34.7-42.6 42.6-29.5 11.7-99.5 9-132.1 9s-102.7 2.6-132.1-9c-19.6-7.8-34.7-22.9-42.6-42.6-11.7-29.5-9-99.5-9-132.1s-2.6-102.7 9-132.1c7.8-19.6 22.9-34.7 42.6-42.6 29.5-11.7 99.5-9 132.1-9s102.7-2.6 132.1 9c19.6 7.8 34.7 22.9 42.6 42.6 11.7 29.5 9 99.5 9 132.1s2.7 102.7-9 132.1z"></path></svg></a><a class="color_black gaevent" href="https://www.clickorlando.com/rss/" gacategory="Nav" gaaction="Footer Social" galabel="https://www.clickorlando.com/rss/"><svg aria-labelledby="svg-inline--fa-title-NEeNdQGNIOZN" data-prefix="fas" data-icon="rss" class="svg-inline--fa fa-rss fa-w-14 " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><title id="svg-inline--fa-title-NEeNdQGNIOZN">rss</title><path fill="currentColor" d="M128.081 415.959c0 35.369-28.672 64.041-64.041 64.041S0 451.328 0 415.959s28.672-64.041 64.041-64.041 64.04 28.673 64.04 64.041zm175.66 47.25c-8.354-154.6-132.185-278.587-286.95-286.95C7.656 175.765 0 183.105 0 192.253v48.069c0 8.415 6.49 15.472 14.887 16.018 111.832 7.284 201.473 96.702 208.772 208.772.547 8.397 7.604 14.887 16.018 14.887h48.069c9.149.001 16.489-7.655 15.995-16.79zm144.249.288C439.596 229.677 251.465 40.445 16.503 32.01 7.473 31.686 0 38.981 0 48.016v48.068c0 8.625 6.835 15.645 15.453 15.999 191.179 7.839 344.627 161.316 352.465 352.465.353 8.618 7.373 15.453 15.999 15.453h48.068c9.034-.001 16.329-7.474 16.005-16.504z"></path></svg></a></div></div><div class="omne"><h6 class="color_black uppercase">Get Results with Omne</h6><a href="https://omneresults.com/" target="_blank" rel="noreferrer"><img src="https://www.clickorlando.com/static-resources/shared/images/omneLogo.svg" alt="Omne Results Logo" width="192" height="56"/></a></div></div></div><p class="no-margin color_black box_content width_max mCenter" style="margin-bottom:3rem;padding:0 1.5rem">If you need help with the Public File, call 407-291-6000.</p><div class="corporate box_content mCenter width_max"><hr class="width_full regular" style="margin-bottom:3rem"/><div class="display_flex align_items_center width_max"><div class="logos display_flex mb-med"><a href="https://www.grahammedia.com/" target="_blank" rel="noreferrer"><img src="https://www.clickorlando.com/static-resources/shared/images/gmg_dark.svg" alt="Graham Media Group Logo" width="96" height="43"/></a><a href="https://hello.grahamdigital.com/" target="_blank" rel="noreferrer"><img src="https://www.clickorlando.com/static-resources/shared/images/gd_dark.svg" alt="Graham Digital Logo" width="96" height="42"/></a></div><div class="copyright color_black"><span>Copyright © </span>2021<!-- --> <!-- -->ClickOrlando.com<!-- --> <!-- -->is managed by Graham Digital and pubished by Graham Media Group, a division of Graham Holdings.</div></div></div><div id="fusion-static-exit:0fH6IRQdGrW" style="display:none" data-fusion-component="0fH6IRQdGrW"></div></footer></div><script id="fusion-metadata" type="application/javascript">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</script><iframe name="__uspapiLocator" style="display:none" title="__uspapilocator"></iframe><script src="https://ak.sail-horizon.com/spm/spm.v1.min.js" async="" defer=""></script></body></html>